aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2023-05-02 15:08:31 -0400
committerHorea Christian <chr@chymera.eu>2023-05-02 15:15:14 -0400
commit754a211496a630db2841613ef2460e96963b6f38 (patch)
treedbd810d3f4f6d7194714ca1d92098c60934e1712 /dev-vcs/datalad/datalad-0.18.1.ebuild
parentdev-python/annexremote: update SRC_URI, PYTHON_COMPAT, PEP517 bump (diff)
downloadsci-754a211496a630db2841613ef2460e96963b6f38.tar.gz
sci-754a211496a630db2841613ef2460e96963b6f38.tar.bz2
sci-754a211496a630db2841613ef2460e96963b6f38.zip
dev-vcs/datalad: brought back
This reverts commit 7405c8639adafc1064f8d4a5d023d786728422bf. Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-vcs/datalad/datalad-0.18.1.ebuild')
-rw-r--r--dev-vcs/datalad/datalad-0.18.1.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/dev-vcs/datalad/datalad-0.18.1.ebuild b/dev-vcs/datalad/datalad-0.18.1.ebuild
new file mode 100644
index 000000000..69b1a5cb5
--- /dev/null
+++ b/dev-vcs/datalad/datalad-0.18.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_10 )
+inherit distutils-r1
+
+DESCRIPTION="Keep code, data, containers under control with git and git-annex"
+HOMEPAGE="https://github.com/datalad/datalad"
+SRC_URI="https://github.com/datalad/datalad/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test +downloaders +metadata +publish misc"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
+ app-arch/p7zip
+ app-arch/patool[${PYTHON_USEDEP}]
+ dev-python/annexremote[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/fasteners[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/iso8601[${PYTHON_USEDEP}]
+ dev-python/looseversion[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/wraps[${PYTHON_USEDEP}]
+ dev-vcs/git-annex
+ downloaders? (
+ dev-python/boto[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/keyrings-alt[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+ metadata? (
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/whoosh[${PYTHON_USEDEP}]
+ )
+ misc? (
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ dev-python/pyperclip[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ )
+ publish? (
+ dev-vcs/python-gitlab[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/httpretty[${PYTHON_USEDEP}]
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+# Also wants test dep:
+# dev-python/types-requests
+# dev-python/types-python-dateutil
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x DATALAD_TESTS_NONETWORK=1
+ # see test groups in "tox.ini"
+ epytest -k "not turtle and not slow and not usecase"
+}