aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2005-12-02 00:51:15 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2005-12-02 00:51:15 +0000
commitf61fdaeb01483bb0006caf26c333c57ed53abe01 (patch)
tree0000e93aa62f2b19803830034e2790431db3369d /sci-astronomy/ds9/ds9-4.0_beta7.ebuild
parentAdding ebuild for kseg (diff)
downloadsci-f61fdaeb01483bb0006caf26c333c57ed53abe01.tar.gz
sci-f61fdaeb01483bb0006caf26c333c57ed53abe01.tar.bz2
sci-f61fdaeb01483bb0006caf26c333c57ed53abe01.zip
Added new ebuild for ds9-4.0_beta7
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@28 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-astronomy/ds9/ds9-4.0_beta7.ebuild')
-rw-r--r--sci-astronomy/ds9/ds9-4.0_beta7.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sci-astronomy/ds9/ds9-4.0_beta7.ebuild b/sci-astronomy/ds9/ds9-4.0_beta7.ebuild
new file mode 100644
index 000000000..9521bbda1
--- /dev/null
+++ b/sci-astronomy/ds9/ds9-4.0_beta7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit flag-o-matic eutils
+
+MY_PV="4.0b7"
+DESCRIPTION="Astronomical imaging and data visualization application for FITS images"
+HOMEPAGE="http://hea-www.harvard.edu/RD/ds9"
+SRC_URI="http://hea-www.harvard.edu/saord/download/${PN}/source/${PN}.${MY_PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc xpa"
+DEPEND=">=sys-devel/gcc-3.4
+ virtual/x11"
+RDEPEND="virtual/x11"
+
+S=${WORKDIR}/sao${PN}
+
+# This is a long and fragile compilation
+# which recompiles tcl/tk, blt, funtools, and who knows what else
+# The make install in src_compile only install and strip the ds9 exec
+# One day scientists will use tools like autotools, cmake, scons
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # The patch is to speed up the compilation
+ # (avoid generating tcl man files for ex.)
+ # and avoid local install bugs with symbolic linking.
+ epatch ${FILESDIR}/${PN}-Makefile.patch
+}
+
+src_compile() {
+ ! is-flag -fPIC && append-flags -fPIC
+ sed -i -e '1i #!/bin/sh' funtools-*/filter/inc.sed
+ use x86 && ln -s make.linux make.include
+ use amd64 && ln -s make.linux64 make.include
+ emake -j1 || die "emake failed"
+ make install || die "make install (local) failed"
+}
+
+src_install () {
+ dobin bin/ds9 || die "dobin ds9 failed"
+ if use xpa; then
+ dobin bin/xpa* || die "dobin xpa failed"
+ doman man/man?/xpa* || die "doman xpa failed"
+ fi
+ dodoc README acknowledgement copyright || die "dodoc failed"
+ use doc && dohtml ds9/doc/* || die "dohtml failed"
+}