aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2018-03-31 02:15:01 +0200
committerMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2018-03-31 02:15:01 +0200
commit3724acdd4d192ac400d81a94f91e957c0e832ccd (patch)
treeb00bb363dea5fd770180004346ca6ec97112c879 /sci-biology/BRAKER/BRAKER-2.1.0.ebuild
parentsci-biology/bamql: new package (diff)
downloadsci-3724acdd4d192ac400d81a94f91e957c0e832ccd.tar.gz
sci-3724acdd4d192ac400d81a94f91e957c0e832ccd.tar.bz2
sci-3724acdd4d192ac400d81a94f91e957c0e832ccd.zip
sci-biology/BRAKER: version bump, update LICENSE
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sci-biology/BRAKER/BRAKER-2.1.0.ebuild')
-rw-r--r--sci-biology/BRAKER/BRAKER-2.1.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-biology/BRAKER/BRAKER-2.1.0.ebuild b/sci-biology/BRAKER/BRAKER-2.1.0.ebuild
new file mode 100644
index 000000000..13d63d4b8
--- /dev/null
+++ b/sci-biology/BRAKER/BRAKER-2.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PERL_EXPORT_PHASE_FUNCTIONS=no
+inherit perl-module
+
+DESCRIPTION="Gene prediction based on RNA-Seq using GeneMark-ET and AUGUSTUS"
+# http://bioinf.uni-greifswald.de/bioinf/publications/pag2015.pdf
+HOMEPAGE="http://bioinf.uni-greifswald.de/bioinf/braker
+ http://bioinf.uni-greifswald.de/augustus/downloads"
+SRC_URI="http://bioinf.uni-greifswald.de/augustus/binaries/BRAKER_v"${PV}".tar.gz -> ${P}.tar.gz"
+# Example data for testing the BRAKER2 pipeline is available at
+# http://bioinf.uni-greifswald.de/augustus/binaries/BRAKER2examples.tar.gz (1.1 GB).
+
+# BRAKER2 is using the Artistic-1.0 version without clause 8 about
+# commercial distribution
+# See discussion at https://opensource.org/licenses/artistic-license-1.0
+# Practically the license is same as http://dev.perl.org/licenses/artistic.html
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-perl/Scalar-Util-Numeric
+ sci-biology/augustus"
+ #>=sci-biology/GeneMark_ET-bin-4.29"
+
+S="${WORKDIR}"/BRAKER_v"${PV}"
+
+src_install(){
+ perl_set_version
+ dobin *.pl
+ insinto ${VENDOR_LIB}/${PN}
+ doins *.pm
+ dodoc userguide.pdf
+}
+
+pkg_postinst(){
+ einfo "Please install sci-biology/GeneMark_ET after obtaininig a license and binaries from"
+ einfo "http://exon.gatech.edu/GeneMark/gmes_instructions.html"
+}