aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2015-11-13 18:26:00 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2015-11-13 18:26:00 +0100
commitc10c56b06fbaf0b0127db70aa6ad7b7910694d2e (patch)
treeaf086269e6f2d4822dd136f45511627287c1b918 /sci-biology/SEECER/SEECER-0.1.3-r2.ebuild
parentsci-biology/BBmap-34.56: restoring previous working version (diff)
downloadsci-c10c56b06fbaf0b0127db70aa6ad7b7910694d2e.tar.gz
sci-c10c56b06fbaf0b0127db70aa6ad7b7910694d2e.tar.bz2
sci-c10c56b06fbaf0b0127db70aa6ad7b7910694d2e.zip
sci-biology/SEECER: remove hardcoded paths
Package-Manager: portage-2.2.18
Diffstat (limited to 'sci-biology/SEECER/SEECER-0.1.3-r2.ebuild')
-rw-r--r--sci-biology/SEECER/SEECER-0.1.3-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-biology/SEECER/SEECER-0.1.3-r2.ebuild b/sci-biology/SEECER/SEECER-0.1.3-r2.ebuild
new file mode 100644
index 000000000..730c4291e
--- /dev/null
+++ b/sci-biology/SEECER/SEECER-0.1.3-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="SEquencing Error Corrector for RNA-Seq reads"
+HOMEPAGE="http://sb.cs.cmu.edu/seecer/"
+SRC_URI="
+ http://sb.cs.cmu.edu/seecer/downloads/"${P}".tar.gz
+ http://sb.cs.cmu.edu/seecer/downloads/manual.pdf -> "${PN}"-manual.pdf"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# although has bundled jellyfish-1.1.11 copy it just calls the executable during runtime
+DEPEND="
+ sci-libs/gsl
+ sci-biology/seqan"
+RDEPEND="${DEPEND}
+ sci-biology/jellyfish"
+
+S="${S}"/SEECER
+
+src_prepare(){
+ # http://seecer-rna-read-error-correction-mailing-list.21961.x6.nabble.com/Segmentation-fault-in-step-4-td41.html
+ cp -p "${FILESDIR}"/replace_ids.cc "${S}"/src/ || die
+ epatch "${FILESDIR}"/remove-hardcoded-paths.patch
+}
+
+src_install(){
+ dobin bin/seecer bin/random_sub_N bin/replace_ids bin/run_jellyfish.sh bin/run_seecer.sh
+ dodoc README "${DISTDIR}"/"${PN}"-manual.pdf
+}