aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-06-16 21:07:14 +0200
committerJustin Lecher <jlec@gentoo.org>2013-06-16 21:07:14 +0200
commitfd12f80985bdcfcfe457ba734c632fb97c3375b5 (patch)
tree375b72f776806ff11bf1b7fc35265b1cd699ca89 /sci-biology/clover/clover-2011.10.24.ebuild
parentsci-chemistry/pymol-plugins-psico: Bump to EAPI=5 and distutils-r1.eclass (diff)
downloadsci-fd12f80985bdcfcfe457ba734c632fb97c3375b5.tar.gz
sci-fd12f80985bdcfcfe457ba734c632fb97c3375b5.tar.bz2
sci-fd12f80985bdcfcfe457ba734c632fb97c3375b5.zip
sci-biology/clover: Version BUmp; fixed license; respect LDFLAGS
Package-Manager: portage-2.2.0_alpha180
Diffstat (limited to 'sci-biology/clover/clover-2011.10.24.ebuild')
-rw-r--r--sci-biology/clover/clover-2011.10.24.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-biology/clover/clover-2011.10.24.ebuild b/sci-biology/clover/clover-2011.10.24.ebuild
new file mode 100644
index 000000000..cfb057432
--- /dev/null
+++ b/sci-biology/clover/clover-2011.10.24.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit toolchain-funcs versionator
+
+MY_PV=$(replace_all_version_separators '-')
+
+DESCRIPTION="Cis-eLement OVERrepresentation: Detection of functional DNA motifs"
+HOMEPAGE="http://zlab.bu.edu/clover/"
+SRC_URI="
+ http://zlab.bu.edu/~mfrith/downloads/${PN}-${MY_PV}.tar.gz
+ http://zlab.bu.edu/clover/jaspar2009core"
+
+LICENSE="freedist"
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86 ~amd64"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ sed \
+ -e "s:g++:$(tc-getCXX) \$(LDFLAGS):; s:-Wall -O3:${CFLAGS}:" \
+ -i Makefile || die "sed failed"
+}
+
+src_install() {
+ dobin clover
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}/jaspar2009core"
+}
+
+pkg_postinst() {
+ einfo "The motif library jaspar2009core has been installed in"
+ einfo " /usr/share/clover/jaspar2009core"
+ einfo "You can pass this library to clover for motif search, or use your own library."
+}