aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2015-05-02 00:40:41 +0200
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2015-05-02 00:40:41 +0200
commitcca8132f7c8070e2d6c06e0efbe01a1860a92fba (patch)
tree75bba3d32c5b05a93fbb99294faa464672c1e2c8 /sci-biology/hexamer/hexamer-19990330.ebuild
parentsci-libs/lighter: new package; contains IUSE=threads but ... does the Makefil... (diff)
downloadsci-cca8132f7c8070e2d6c06e0efbe01a1860a92fba.tar.gz
sci-cca8132f7c8070e2d6c06e0efbe01a1860a92fba.tar.bz2
sci-cca8132f7c8070e2d6c06e0efbe01a1860a92fba.zip
sci-biology/hexamer: new package
Package-Manager: portage-2.2.18
Diffstat (limited to 'sci-biology/hexamer/hexamer-19990330.ebuild')
-rw-r--r--sci-biology/hexamer/hexamer-19990330.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-biology/hexamer/hexamer-19990330.ebuild b/sci-biology/hexamer/hexamer-19990330.ebuild
new file mode 100644
index 000000000..fda4818ce
--- /dev/null
+++ b/sci-biology/hexamer/hexamer-19990330.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Predict CDS using 6mers without deriving information from base composition"
+HOMEPAGE="http://www.sanger.ac.uk/resources/software"
+SRC_URI="ftp://ftp.sanger.ac.uk/pub/users/rd/hexamer.tar.gz -> hexamer-19990330.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/hexamer
+
+src_prepare(){
+ sed -e "s#cc -g#$(tc-getCC) ${CFLAGS}#" -i Makefile || die
+}
+
+src_install(){
+ dobin hexamer hextable
+ dodoc README
+}