aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2018-04-22 13:45:10 +0200
committerMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2018-04-22 13:45:10 +0200
commit8ee8fd95880516f79f8693c728d0ec218fa82277 (patch)
tree91ddb4d0be642996ef475daf562578a6209276f1 /sci-biology/kat/kat-2.4.1.ebuild
parentsci-biology/kat: execute the build_boost.sh and autogen.sh logic (diff)
downloadsci-8ee8fd95880516f79f8693c728d0ec218fa82277.tar.gz
sci-8ee8fd95880516f79f8693c728d0ec218fa82277.tar.bz2
sci-8ee8fd95880516f79f8693c728d0ec218fa82277.zip
sci-biology/kat: ignore site-wide boost-build/site-config.jam
Introduce -8888 ebuild which zaps bundled stuff altogether and uses system-wide boost and jellyfish2 files. Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'sci-biology/kat/kat-2.4.1.ebuild')
-rw-r--r--sci-biology/kat/kat-2.4.1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sci-biology/kat/kat-2.4.1.ebuild b/sci-biology/kat/kat-2.4.1.ebuild
index 1df9f4430..f1635e9e8 100644
--- a/sci-biology/kat/kat-2.4.1.ebuild
+++ b/sci-biology/kat/kat-2.4.1.ebuild
@@ -41,7 +41,7 @@ src_prepare(){
src_configure(){
local myconf=()
myconf+=( --disable-gnuplot ) # python3 does better image rendering, no need for gnuplot
- use cpu_flags_x86_sse && myconf+=( $(use_with cpu_flags_x86_sse sse) ) # pass down to jellyfish-2.20/configure
+ use cpu_flags_x86_sse && myconf+=( $(use_with cpu_flags_x86_sse sse) ) # pass down to jellyfish-2.2.0/configure
PYTHON_VERSION=3 econf ${myconf[@]}
}
@@ -49,7 +49,8 @@ src_compile(){
# build_boost.sh
cd deps/boost || die
./bootstrap.sh --prefix=build --with-libraries=chrono,exception,program_options,timer,filesystem,system,stacktrace || die
- ./b2 headers || die
- ./b2 install || die
+ # https://github.com/TGAC/KAT/issues/92#issuecomment-383373418
+ ./b2 headers --ignore-site-config || die
+ ./b2 install --ignore-site-config || die
cd ../.. || die
}