aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-22 20:18:53 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-22 20:18:53 +0100
commit215494670034cdd35fefed02a709f18b36b88f64 (patch)
tree6925ee952eb085e2d70d8f7eea17996f7efa5f5e /sci-biology/repeatmasker
parentsci-biology/OBO-Edit: Use ecvs_clean to clean workdir (diff)
downloadsci-215494670034cdd35fefed02a709f18b36b88f64.tar.gz
sci-215494670034cdd35fefed02a709f18b36b88f64.tar.bz2
sci-215494670034cdd35fefed02a709f18b36b88f64.zip
Fix usage of die with ebuild_helper
Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-biology/repeatmasker')
-rw-r--r--sci-biology/repeatmasker/repeatmasker-4.0.6-r2.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/sci-biology/repeatmasker/repeatmasker-4.0.6-r2.ebuild b/sci-biology/repeatmasker/repeatmasker-4.0.6-r2.ebuild
index 86be5affe..18e3e697e 100644
--- a/sci-biology/repeatmasker/repeatmasker-4.0.6-r2.ebuild
+++ b/sci-biology/repeatmasker/repeatmasker-4.0.6-r2.ebuild
@@ -68,19 +68,20 @@ Y
src_install() {
exeinto /usr/share/${PN}
for i in DateRepeats ProcessRepeats RepeatMasker DupMasker RepeatProteinMask; do
- doexe $i || die
- dosym /usr/share/${PN}/$i /usr/bin/$i || die
+ doexe $i
+ dosym /usr/share/${PN}/$i /usr/bin/$i
done
dodir /usr/share/${PN}/lib
insinto /usr/share/${PN}/lib
doins "${S}"/*.pm "${S}"/Libraries/*.pm
- rm -rf "${S}"/Libraries/*.pm # zap the supposedly misplaced RepeatAnnotationData.pm file
+ # zap the supposedly misplaced RepeatAnnotationData.pm file
+ rm -rf "${S}"/Libraries/*.pm || die
# if sci-biology/repeatmasker-libraries is installed prevent file collision
# and do NOT install Libraries/RepeatMaskerLib.embl file which contains
# a limited version of the file: 20110419-min
- rm -rf Libraries/RepeatMaskerLib.embl
+ rm -rf Libraries/RepeatMaskerLib.embl || die
insinto /usr/share/${PN}
doins -r util Matrices Libraries *.help
keepdir /usr/share/${PN}/Libraries