aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <kislyuk@devel.(none)>2009-02-19 15:15:03 -0500
committerAndrey Kislyuk <kislyuk@devel.(none)>2009-02-19 15:15:03 -0500
commite31cbec391be6debeebc4f702483f2c2f19bf499 (patch)
tree4168334ebf36b42ba5becca31f6c8f8f3fd92d0b /sci-biology/trf/trf-4.0.ebuild
parentGAMESS - Version bump (diff)
downloadsci-e31cbec391be6debeebc4f702483f2c2f19bf499.tar.gz
sci-e31cbec391be6debeebc4f702483f2c2f19bf499.tar.bz2
sci-e31cbec391be6debeebc4f702483f2c2f19bf499.zip
new package sci-biology/trf
Diffstat (limited to 'sci-biology/trf/trf-4.0.ebuild')
-rw-r--r--sci-biology/trf/trf-4.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-biology/trf/trf-4.0.ebuild b/sci-biology/trf/trf-4.0.ebuild
new file mode 100644
index 000000000..377b9e1e3
--- /dev/null
+++ b/sci-biology/trf/trf-4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Tandem Repeats Finder"
+HOMEPAGE="http://tandem.bu.edu/trf/trf.html"
+SRC_URI="http://tandem.bu.edu/trf/downloads/trf400.linux.exe"
+
+LICENSE="as-is"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND=""
+# gtk? ( x11-libs/gtk+ ) x11-libs/pango[X]
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/trf400.linux.exe" "${S}"
+}
+
+src_install() {
+ exeinto /opt/${PN}
+ doexe trf400.linux.exe || die
+ dosym /opt/${PN}/trf400.linux.exe /usr/bin/trf || die
+ # GTK version (http://tandem.bu.edu/trf/downloads/trf400.linuxgtk.exe) has broken linking
+ #if use gtk; then
+ # doexe trf400.linuxgtk.exe || die
+ # make_desktop_entry /opt/${PN}/trf400.linuxgtk.exe "Tandem Repeats Finder" || die
+ #fi
+}