aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher (jlec) <jlec@j-schmitz.net>2009-07-06 21:48:23 +0200
committerJustin Lecher (jlec) <jlec@j-schmitz.net>2009-07-07 21:51:49 +0200
commitcdf3203be0c831d172bff20824b9d53f76bd8aec (patch)
tree2f9fba441d3141d534ddea5e9df8322fffc154d2 /sci-chemistry/xia2/xia2-0.3.0.0-r1.ebuild
parentIn gentoo-x86 (diff)
downloadsci-cdf3203be0c831d172bff20824b9d53f76bd8aec.tar.gz
sci-cdf3203be0c831d172bff20824b9d53f76bd8aec.tar.bz2
sci-cdf3203be0c831d172bff20824b9d53f76bd8aec.zip
xdsi kpdf -> xpdf fix
Diffstat (limited to 'sci-chemistry/xia2/xia2-0.3.0.0-r1.ebuild')
-rw-r--r--sci-chemistry/xia2/xia2-0.3.0.0-r1.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/sci-chemistry/xia2/xia2-0.3.0.0-r1.ebuild b/sci-chemistry/xia2/xia2-0.3.0.0-r1.ebuild
new file mode 100644
index 000000000..f14e694b8
--- /dev/null
+++ b/sci-chemistry/xia2/xia2-0.3.0.0-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+FORTRANC="g77 gfortran ifc"
+
+inherit eutils python fortran
+
+DESCRIPTION="An automated data reduction system for crystallography"
+HOMEPAGE="http://www.ccp4.ac.uk/xia/"
+SRC_URI="${HOMEPAGE}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sci-chemistry/ccp4-6.1.1-r5
+ sci-chemistry/pointless
+ sci-chemistry/mosflm
+ >=sci-libs/ccp4-libs-6.1.1-r7"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ find . -name '*.bat' | xargs rm || die
+
+ epatch "${FILESDIR}"/${PV}-fix-syntax.patch
+}
+
+src_compile() {
+ cd "${S}"/${P}/binaries/src
+ cp "${FILESDIR}"/Makefile.chef Makefile
+ emake \
+ FC="${FORTRANC}" || die
+}
+
+src_install() {
+ dobin ${P}/binaries/src/{doser,chef,mat2symop,symop2mat} || die
+
+ rm -rf ${P}/binaries ${PN}core-${PV}/Test || die
+
+ insinto /usr/share/ccp4/XIAROOT/
+ doins -r * || die
+
+ # Set programs executable
+# fperms cannot handle wildcards
+ chmod 755 "${D}"/usr/share/ccp4/XIAROOT/${P}/Applications/* || die
+ chmod 644 "${D}"/usr/share/ccp4/XIAROOT/${P}/Applications/*.py || die
+
+ cat >> "${T}"/23XIA <<- EOF
+ XIA2_HOME=/usr/share/ccp4/XIAROOT
+
+ XIA2CORE_ROOT=/usr/share/ccp4/XIAROOT/xia2core-${PV}
+ XIA2_ROOT=/usr/share/ccp4/XIAROOT/xia2-${PV}
+
+ PATH=/usr/share/ccp4/XIAROOT/xia2-${PV}/Applications
+ EOF
+
+ doenvd "${T}"/23XIA
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/ccp4/XIAROOT
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/ccp4/XIAROOT
+}