aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-22 11:09:45 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-22 11:09:45 +0200
commita6da897dd959421eca4a78deee4f55faff97c77b (patch)
tree6a0a4b869eb19905c96ddbf4d4abe37b655f76f7 /sci-chemistry
parentdev-python/matplotlib2tikz: Version bump to 0.2.4 (diff)
downloadsci-a6da897dd959421eca4a78deee4f55faff97c77b.tar.gz
sci-a6da897dd959421eca4a78deee4f55faff97c77b.tar.bz2
sci-a6da897dd959421eca4a78deee4f55faff97c77b.zip
Drop deprecated python eclass function
Parallel support has been removed from pyhton eclasses python_parallel_foreach_impl -> python_foreach_impl Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/openbabel-python/openbabel-python-9999.ebuild2
-rw-r--r--sci-chemistry/pymol-plugins-ezviz/pymol-plugins-ezviz-1.0.2005-r1.ebuild2
-rw-r--r--sci-chemistry/shiftx2/shiftx2-1.07_p20120106.ebuild10
-rw-r--r--sci-chemistry/smmp/smmp-3.0.5.ebuild4
4 files changed, 9 insertions, 9 deletions
diff --git a/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild b/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild
index 8de879c1b..69c0acd90 100644
--- a/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild
+++ b/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild
@@ -63,7 +63,7 @@ src_configure() {
}
src_compile() {
- python_parallel_foreach_impl cmake-utils_src_make bindings_python
+ python_foreach_impl cmake-utils_src_make bindings_python
}
src_test() {
diff --git a/sci-chemistry/pymol-plugins-ezviz/pymol-plugins-ezviz-1.0.2005-r1.ebuild b/sci-chemistry/pymol-plugins-ezviz/pymol-plugins-ezviz-1.0.2005-r1.ebuild
index 5ba646f61..74f642631 100644
--- a/sci-chemistry/pymol-plugins-ezviz/pymol-plugins-ezviz-1.0.2005-r1.ebuild
+++ b/sci-chemistry/pymol-plugins-ezviz/pymol-plugins-ezviz-1.0.2005-r1.ebuild
@@ -51,6 +51,6 @@ src_install() {
python_domodule *.gif
}
python_foreach_impl installation
- python_parallel_foreach_impl python_optimize
+ python_foreach_impl python_optimize
dodoc readme.txt
}
diff --git a/sci-chemistry/shiftx2/shiftx2-1.07_p20120106.ebuild b/sci-chemistry/shiftx2/shiftx2-1.07_p20120106.ebuild
index e72cb8272..9baabd491 100644
--- a/sci-chemistry/shiftx2/shiftx2-1.07_p20120106.ebuild
+++ b/sci-chemistry/shiftx2/shiftx2-1.07_p20120106.ebuild
@@ -98,11 +98,11 @@ src_install() {
local instdir="/opt/${PN}"
dodoc README 1UBQ.pdb
- python_parallel_foreach_impl python_newscript ${PN}.py ${PN}
+ python_foreach_impl python_newscript ${PN}.py ${PN}
mv shiftx2_util.py shiftx2util.py || die
python_moduleinto ${PN}
touch __init__.py
- python_parallel_foreach_impl python_domodule natsorted.py shiftx2util.py __init__.py
+ python_foreach_impl python_domodule natsorted.py shiftx2util.py __init__.py
# other modules
dobin \
@@ -111,12 +111,12 @@ src_install() {
"${S}"/modules/effects/caleffect
# script
- python_parallel_foreach_impl python_doscript "${S}"/script/*py
+ python_foreach_impl python_doscript "${S}"/script/*py
exeinto ${instdir}/script
doexe "${S}"/script/*.r
# shifty3
- python_parallel_foreach_impl python_newscript "${S}"/shifty3/*py shifty3
+ python_foreach_impl python_newscript "${S}"/shifty3/*py shifty3
exeinto ${instdir}/shifty3
doexe "${S}"/shifty3/xalign_x
dosym ../${PN}/shifty3/xalign_x /opt/bin/xalign_x
@@ -124,6 +124,6 @@ src_install() {
insinto ${instdir}/shifty3
doins -r "${S}"/shifty3/{blastdb,refdb,xalign.parms,wt.rbo}
- python_parallel_foreach_impl python_doscript "${S}"/shifty3/utils/*py
+ python_foreach_impl python_doscript "${S}"/shifty3/utils/*py
dobin "${S}"/shifty3/utils/create_blastdb.sh
}
diff --git a/sci-chemistry/smmp/smmp-3.0.5.ebuild b/sci-chemistry/smmp/smmp-3.0.5.ebuild
index 2ab9f0063..9914ab5fe 100644
--- a/sci-chemistry/smmp/smmp-3.0.5.ebuild
+++ b/sci-chemistry/smmp/smmp-3.0.5.ebuild
@@ -54,7 +54,7 @@ src_test() {
src_install() {
dobin ${PN}
python_moduleinto ${PN}
- python_parallel_foreach_impl python_domodule *.py
- python_parallel_foreach_impl python_optimize
+ python_foreach_impl python_domodule *.py
+ python_foreach_impl python_optimize
dodoc README
}