aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <francois@vrooom.(none)>2009-11-23 15:01:12 +1300
committerFrançois Bissey <francois@vrooom.(none)>2009-11-23 15:01:49 +1300
commit332f8a4a9fa38f5891cb62d6bf78573f2d53a0dd (patch)
treedc40fa4ecb7a7228702b05dbf718c41c6a65b98f /sci-libs/iml/files
parentFix openib.init.d and env.d (diff)
downloadsci-332f8a4a9fa38f5891cb62d6bf78573f2d53a0dd.tar.gz
sci-332f8a4a9fa38f5891cb62d6bf78573f2d53a0dd.tar.bz2
sci-332f8a4a9fa38f5891cb62d6bf78573f2d53a0dd.zip
Importing iml-1.0.3
Diffstat (limited to 'sci-libs/iml/files')
-rw-r--r--sci-libs/iml/files/fix-undefined-symbol.patch11
-rw-r--r--sci-libs/iml/files/iml-1.0.3-cblas.patch41
2 files changed, 52 insertions, 0 deletions
diff --git a/sci-libs/iml/files/fix-undefined-symbol.patch b/sci-libs/iml/files/fix-undefined-symbol.patch
new file mode 100644
index 000000000..1521d1536
--- /dev/null
+++ b/sci-libs/iml/files/fix-undefined-symbol.patch
@@ -0,0 +1,11 @@
+--- nullspace.c.orig 2008-08-12 15:17:18.000000000 +0200
++++ nullspace.c 2008-08-12 15:12:15.000000000 +0200
+@@ -253,7 +253,7 @@
+ for (i = 0; i < m; i++) {
+ for (j = 0; j < m; j++)
+ mpz_init_set_ui(mp_N[i * m + j], 0);
+- mpz_init_ui(mp_N[i * m + i], 1);
++ mpz_init_set_ui(mp_N[i * m + i], 1);
+ }
+ *mp_N_pass = mp_N;
+ } else { /* r>0 and s>0 */
diff --git a/sci-libs/iml/files/iml-1.0.3-cblas.patch b/sci-libs/iml/files/iml-1.0.3-cblas.patch
new file mode 100644
index 000000000..c9a6a1faa
--- /dev/null
+++ b/sci-libs/iml/files/iml-1.0.3-cblas.patch
@@ -0,0 +1,41 @@
+--- configure.ac.orig 2009-11-23 09:30:12.000000000 +1300
++++ configure.ac 2009-11-23 11:35:59.000000000 +1300
+@@ -3,6 +3,7 @@
+ AC_PREREQ(2.59)
+ AC_INIT(IML, 1.0.3)
+ AC_CONFIG_AUX_DIR(config)
++AC_CONFIG_MACRO_DIR(config)
+ AM_CONFIG_HEADER(config.h:config-h.in)
+ AC_CONFIG_SRCDIR([src/RNSop.c])
+ AM_INIT_AUTOMAKE
+@@ -55,11 +56,18 @@
+ respectively when running configure.
+ )])
+
+-IML_CHECK_ATLAS(,,[AC_MSG_ERROR(
+-ATLAS not found!
+-ATLAS version 3.0 or greater is required for this library to compile. Please make sure ATLAS is installed and specify the header and libraries location with the options --with-atlas-include=<path> and --with-atlas-lib=<path> respectively when running configure.
+-)])
++AC_CHECK_HEADERS([cblas.h],
++ [cblas_headers_found=yes; break;])
++
++AS_IF([test "x$cblas_headers_found" != "xyes"],
++ [AC_MSG_ERROR([Unable to find the cblas headers check your installation])])
++
++AC_ARG_WITH(cblas-lib,
++ AC_HELP_STRING([--with-cblas-lib=<lib>],[Specify the flags for cblas.]),
++ with_cblas_lib=$withval)
++ATLAS_LIBS="$with_cblas_lib"
+
++AC_SUBST(ATLAS_LIBS)
+ AC_SUBST(LDFLAGS)
+ AC_SUBST(ac_aux_dir)
+
+--- Makefile.am~ 2009-11-23 11:38:44.000000000 +1300
++++ Makefile.am 2009-11-23 11:38:44.000000000 +1300
+@@ -1,3 +1,5 @@
++ACLOCAL_AMFLAGS = -I config
++
+ EXTRA_DIST = bootstrap
+
+ SUBDIRS = repl config src doc tests examples