aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-04-03 12:49:54 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-04-03 12:49:54 +0200
commite362f42f3143e43270708ab82b90f2bdb4da2335 (patch)
treeb4cd53fa5b9b9a6b4abd92d207bbd7b00e98ffbf /sci-libs/iml/iml-1.0.4.ebuild
parentsci-libs/iml: Bump to EAPI=5 (diff)
downloadsci-e362f42f3143e43270708ab82b90f2bdb4da2335.tar.gz
sci-e362f42f3143e43270708ab82b90f2bdb4da2335.tar.bz2
sci-e362f42f3143e43270708ab82b90f2bdb4da2335.zip
sci-libs/iml: Version bump
Package-Manager: portage-2.2.14
Diffstat (limited to 'sci-libs/iml/iml-1.0.4.ebuild')
-rw-r--r--sci-libs/iml/iml-1.0.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-libs/iml/iml-1.0.4.ebuild b/sci-libs/iml/iml-1.0.4.ebuild
new file mode 100644
index 000000000..8be9c4731
--- /dev/null
+++ b/sci-libs/iml/iml-1.0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Integer Matrix Library"
+HOMEPAGE="http://www.cs.uwaterloo.ca/~astorjoh/iml.html"
+SRC_URI="http://www.cs.uwaterloo.ca/~astorjoh/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RESTRICT="mirror"
+
+DEPEND="virtual/cblas"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_AUTORECONF=yes
+AT_M4DIR="config"
+DOCS=( AUTHORS ChangeLog README )
+PATCHES=(
+ "${FILESDIR}"/${P}-use-any-cblas-implementation.patch
+)
+
+src_configure() {
+ myeconfargs=(
+ --with-default="${EPREFIX}"/usr
+ )
+ autotools-utils_src_configure
+}