aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik (Xarthisius) <xarthisius@gentoo.org>2013-09-15 07:18:11 +0200
committerKacper Kowalik (Xarthisius) <xarthisius@gentoo.org>2013-09-15 07:18:11 +0200
commit4ffb04de8cc4f64a6eb0582ceac43dbc2999cbbc (patch)
tree95b1a4d2ccc78b78e699ce7834e33dc8c8c902d2 /sci-libs/nipy
parent[dev-python/Forthon] version bump (diff)
parentsci-chemistry/freeon-20130912: Added new version. (diff)
downloadsci-4ffb04de8cc4f64a6eb0582ceac43dbc2999cbbc.tar.gz
sci-4ffb04de8cc4f64a6eb0582ceac43dbc2999cbbc.tar.bz2
sci-4ffb04de8cc4f64a6eb0582ceac43dbc2999cbbc.zip
Merge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/sci
Diffstat (limited to 'sci-libs/nipy')
-rw-r--r--sci-libs/nipy/Manifest1
-rw-r--r--sci-libs/nipy/metadata.xml12
-rw-r--r--sci-libs/nipy/nipy-0.3.0.ebuild37
-rw-r--r--sci-libs/nipy/nipy-9999.ebuild36
4 files changed, 86 insertions, 0 deletions
diff --git a/sci-libs/nipy/Manifest b/sci-libs/nipy/Manifest
new file mode 100644
index 000000000..e2730eee9
--- /dev/null
+++ b/sci-libs/nipy/Manifest
@@ -0,0 +1 @@
+DIST nipy-0.3.0.tar.gz 2143887 SHA256 74fef65c832795a35e1757d8bd852177fae190517a964afcb0812cfc1107d155 SHA512 3eaab4628bfa1706c99d516242387e1a27330bbf03b5b79da80d9a5e697b4e779f8f059e6f7bcc4253c5ad7af1bf6c600bcc5bd87db95d2e38f445d1f4416106 WHIRLPOOL 8a27c42abd8c7ae5ce66b8cfb0686b79e3208950107fcc5090d88fa2c23bf15d4ce4ae5b598f6f51c6e70122c40a343b9b7b2950ef09aefaeb22e24efd854af0
diff --git a/sci-libs/nipy/metadata.xml b/sci-libs/nipy/metadata.xml
new file mode 100644
index 000000000..ac599a834
--- /dev/null
+++ b/sci-libs/nipy/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>h.chr@mail.ru</email>
+ <name>Horea Christian</name>
+</maintainer>
+<longdescription lang="en">
+ NIPY is a python project for analysis of structural and functional neuroimaging data.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/nipy/nipy-0.3.0.ebuild b/sci-libs/nipy/nipy-0.3.0.ebuild
new file mode 100644
index 000000000..4d68e2a82
--- /dev/null
+++ b/sci-libs/nipy/nipy-0.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2} )
+DISTUTILS_NO_PARALLEL_BUILD=true
+
+inherit distutils-r1 eutils multilib flag-o-matic
+
+
+DESCRIPTION="Neuroimaging tools for Python"
+HOMEPAGE="http://nipy.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ >=sci-libs/nibabel-1.2[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ # bug #397605
+ [[ ${CHOST} == *-darwin* ]] \
+ && append-ldflags -bundle "-undefined dynamic_lookup" \
+ || append-ldflags -shared
+
+ # nipy uses the horrible numpy.distutils automagic
+}
diff --git a/sci-libs/nipy/nipy-9999.ebuild b/sci-libs/nipy/nipy-9999.ebuild
new file mode 100644
index 000000000..6d752cbde
--- /dev/null
+++ b/sci-libs/nipy/nipy-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scikits_image/scikits_image-0.8.2.ebuild,v 1.3 2013/06/18 04:33:25 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2} )
+DISTUTILS_NO_PARALLEL_BUILD=true
+
+inherit distutils-r1 multilib git-2 flag-o-matic
+
+DESCRIPTION="Neuroimaging tools for Python"
+HOMEPAGE="http://nipy.org/"
+EGIT_REPO_URI="https://github.com/nipy/nipy"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+KEYWORDS=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ >=sci-libs/nibabel-1.2[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ # bug #397605
+ [[ ${CHOST} == *-darwin* ]] \
+ && append-ldflags -bundle "-undefined dynamic_lookup" \
+ || append-ldflags -shared
+
+ # nipy uses the horrible numpy.distutils automagic
+}