aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2018-08-10 03:47:24 +0200
committerHorea Christian <horea.christ@yandex.com>2018-08-10 03:47:24 +0200
commit81bed4e668e2ee6425cc555524189ceb2198a04f (patch)
tree7f948f020ee5bf06821c3a0a50b162e234ecb217 /sci-libs/nipype/nipype-1.1.1.ebuild
parentsci-libs/nipype: version bump (diff)
downloadsci-81bed4e668e2ee6425cc555524189ceb2198a04f.tar.gz
sci-81bed4e668e2ee6425cc555524189ceb2198a04f.tar.bz2
sci-81bed4e668e2ee6425cc555524189ceb2198a04f.zip
sci-libs/nipype: version bump
Package-Manager: Portage-2.3.45, Repoman-2.3.10
Diffstat (limited to 'sci-libs/nipype/nipype-1.1.1.ebuild')
-rw-r--r--sci-libs/nipype/nipype-1.1.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sci-libs/nipype/nipype-1.1.1.ebuild b/sci-libs/nipype/nipype-1.1.1.ebuild
new file mode 100644
index 000000000..8c2713712
--- /dev/null
+++ b/sci-libs/nipype/nipype-1.1.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Neuroimaging in Python: Pipelines and Interfaces"
+HOMEPAGE="http://nipy.sourceforge.net/nipype/"
+SRC_URI="https://github.com/nipy/nipype/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ~dev-python/prov-1.5.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )
+ $(python_gen_cond_dep 'dev-python/configparser[${PYTHON_USEDEP}]' python2_7)
+ "
+RDEPEND="
+ >=dev-python/click-6.6[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pydotplus[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/traits[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ virtual/python-funcsigs[${PYTHON_USEDEP}]
+ "
+
+python_test() {
+ py.test -v --cov nipype\
+ --cov-config .coveragerc\
+ --cov-report xml:cov.xml\
+ -c nipype/pytest.ini\
+ --doctest-modules nipype\
+ || die
+}