aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2018-05-23 02:24:36 +0200
committerHorea Christian <horea.christ@yandex.com>2018-05-23 02:24:36 +0200
commit8c25ca238bd0d2df7e204f6506d7258a6cdf1615 (patch)
treec975317ca17c313eca6308594125df9e0d53670c /sci-libs/pybids/pybids-0.5.0.ebuild
parentdev-python/num2words: new package (pybids dep) (diff)
downloadsci-8c25ca238bd0d2df7e204f6506d7258a6cdf1615.tar.gz
sci-8c25ca238bd0d2df7e204f6506d7258a6cdf1615.tar.bz2
sci-8c25ca238bd0d2df7e204f6506d7258a6cdf1615.zip
sci-libs/pybids: new package
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'sci-libs/pybids/pybids-0.5.0.ebuild')
-rw-r--r--sci-libs/pybids/pybids-0.5.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-libs/pybids/pybids-0.5.0.ebuild b/sci-libs/pybids/pybids-0.5.0.ebuild
new file mode 100644
index 000000000..2a2ecf29e
--- /dev/null
+++ b/sci-libs/pybids/pybids-0.5.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package to access BIDS datasets"
+HOMEPAGE="https://github.com/INCF/pybids"
+SRC_URI="https://github.com/INCF/pybids/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+RDEPEND="
+ dev-python/grabbit[${PYTHON_USEDEP}]
+ dev-python/num2words[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/patsy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ "
+
+# Tests are broken: https://github.com/INCF/pybids/issues/138
+RESTRICT="test"