aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2018-01-29 16:27:43 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2018-01-29 16:27:43 +0100
commit5c3a47ab0a4e38425544636e0de78a915b52878d (patch)
tree2c0cf1b2a06e5762800de0986d4cade5ccb2713a /sci-libs
parentUnmask scilab (diff)
downloadsci-5c3a47ab0a4e38425544636e0de78a915b52878d.tar.gz
sci-5c3a47ab0a4e38425544636e0de78a915b52878d.tar.bz2
sci-5c3a47ab0a4e38425544636e0de78a915b52878d.zip
sci-libs/tensorflow: new package
Will be needed for sci-biology/chiron, landing soon. Package-Manager: Portage-2.3.20, Repoman-2.3.6 RepoMan-Options: --force
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/tensorflow/Manifest2
-rw-r--r--sci-libs/tensorflow/metadata.xml12
-rw-r--r--sci-libs/tensorflow/tensorflow-1.0.1.ebuild27
-rw-r--r--sci-libs/tensorflow/tensorflow-1.5.0.ebuild27
4 files changed, 68 insertions, 0 deletions
diff --git a/sci-libs/tensorflow/Manifest b/sci-libs/tensorflow/Manifest
new file mode 100644
index 000000000..3d31b86e0
--- /dev/null
+++ b/sci-libs/tensorflow/Manifest
@@ -0,0 +1,2 @@
+DIST tensorflow-1.0.1.tar.gz 10919903 BLAKE2B 1ce4de131436b2b7fec909251a8b4c03d872920cbe788eb9914c5670803fc0baf8462d1d6498c9ee3ef4e941bd0286bebda44745ac49d8044627a93fac28c746 SHA512 49f22cd6baca8770401aacd870b30b33f4eaa576c9f2d3caae0a00225d40041352d5300cb3dc5ec90ec9f0e8865eb542a7d3d6a0f39ceb6d0f2606cc4725f0a7
+DIST tensorflow-1.5.0.tar.gz 19155285 BLAKE2B 32000e583b85f195fc62acafc22254d8806b26a59f06b024c2be98c0a3b5770cbfc60f73957a3f11cdbf7488b8891978f73a22b6d642fdd763ecd95f18e38d65 SHA512 63240d72b9946db29279800b1081adc4cc08b6cd7dc35155a529cc335bfc1dd16fb525fb6047f6cc0dcec547a54e7e100698a176ee93f5633965cfab2a8ad9eb
diff --git a/sci-libs/tensorflow/metadata.xml b/sci-libs/tensorflow/metadata.xml
new file mode 100644
index 000000000..138cb7705
--- /dev/null
+++ b/sci-libs/tensorflow/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mmokrejs@fold.natur.cuni.cz</email>
+ <name>Martin Mokrejs</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-libs/tensorflow/tensorflow-1.0.1.ebuild b/sci-libs/tensorflow/tensorflow-1.0.1.ebuild
new file mode 100644
index 000000000..a62394c86
--- /dev/null
+++ b/sci-libs/tensorflow/tensorflow-1.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5,6} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Library for numerical computation using data flow graphs"
+HOMEPAGE="https://github.com/tensorflow/tensorflow"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE="cuda mpi"
+
+DEPEND="dev-util/bazel
+ dev-python/wheel
+ dev-python/numpy
+ dev-libs/protobuf-c
+ cuda? ( x11-drivers/nvidia-drivers dev-util/nvidia-cuda-toolkit )
+ mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+# TODO: seems it also support some MPI implementation
diff --git a/sci-libs/tensorflow/tensorflow-1.5.0.ebuild b/sci-libs/tensorflow/tensorflow-1.5.0.ebuild
new file mode 100644
index 000000000..a62394c86
--- /dev/null
+++ b/sci-libs/tensorflow/tensorflow-1.5.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5,6} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Library for numerical computation using data flow graphs"
+HOMEPAGE="https://github.com/tensorflow/tensorflow"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE="cuda mpi"
+
+DEPEND="dev-util/bazel
+ dev-python/wheel
+ dev-python/numpy
+ dev-libs/protobuf-c
+ cuda? ( x11-drivers/nvidia-drivers dev-util/nvidia-cuda-toolkit )
+ mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+# TODO: seems it also support some MPI implementation