aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2020-09-28 03:17:54 -0400
committerHorea Christian <chr@chymera.eu>2020-09-28 03:17:54 -0400
commitb886b4e53916c3c3ebf31f07c1fc1f375a128c40 (patch)
tree507f448f86422a6bca661cfccc1f0b30345bf5eb /sci-libs
parentsci-libs/libmaus: removed discontinued package (diff)
downloadsci-b886b4e53916c3c3ebf31f07c1fc1f375a128c40.tar.gz
sci-b886b4e53916c3c3ebf31f07c1fc1f375a128c40.tar.bz2
sci-b886b4e53916c3c3ebf31f07c1fc1f375a128c40.zip
sci-libs/libmaus2: updated dependencies
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libmaus2/libmaus2-2.0.587.ebuild13
-rw-r--r--sci-libs/libmaus2/libmaus2-2.0.689.ebuild13
-rw-r--r--sci-libs/libmaus2/libmaus2-9999.ebuild10
3 files changed, 15 insertions, 21 deletions
diff --git a/sci-libs/libmaus2/libmaus2-2.0.587.ebuild b/sci-libs/libmaus2/libmaus2-2.0.587.ebuild
index 593fe083f..9be955b71 100644
--- a/sci-libs/libmaus2/libmaus2-2.0.587.ebuild
+++ b/sci-libs/libmaus2/libmaus2-2.0.587.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,8 +16,6 @@ KEYWORDS="~amd64 ~x86"
IUSE="cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2"
DEPEND="
- !sci-libs/libmaus
- >=sci-libs/io_lib-1.14.11
app-arch/snappy
sci-libs/fftw
sci-libs/hdf5
@@ -25,21 +23,20 @@ DEPEND="
dev-libs/nettle"
# --with-daligner
# --with-irods
-# old github.com release tarballs
-# S="${WORKDIR}"/libmaus2-master-27828cd78121d5e4b19c263c5527e462360f5901
-# current gitlab.com release tarballs
S="${WORKDIR}/${P}-release-${release_data}"
src_configure(){
local CONFIG_OPTS
use cpu_flags_x86_ssse3 && CONFIG_OPTS+=( --enable-ssse3 )
( use cpu_flags_x86_sse4_1 || use cpu_flags_x86_sse4_2 ) && CONFIG_OPTS+=( --enable-sse4 )
- econf --with-snappy --with-io_lib $CONFIG_OPTS \
+ econf --with-snappy $CONFIG_OPTS \
--with-lzma --with-gnutls --with-nettle --with-hdf5 --with-gmp --with-fftw
+ # --with-io_lib
+ # will require >=sci-libs/io_lib-1.14.11 which is not yet available in ::gentoo
}
pkg_postinst(){
- einfo "The io_lib, snappy dependencies are not strictly needed"
+ einfo "The snappy dependency is not strictly needed"
einfo "but were forced for optimal libmaus2 performance."
einfo "igzip is only used if gzip level is set to 11."
}
diff --git a/sci-libs/libmaus2/libmaus2-2.0.689.ebuild b/sci-libs/libmaus2/libmaus2-2.0.689.ebuild
index 50b82d5aa..ff5583090 100644
--- a/sci-libs/libmaus2/libmaus2-2.0.689.ebuild
+++ b/sci-libs/libmaus2/libmaus2-2.0.689.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,8 +16,6 @@ KEYWORDS="~amd64 ~x86"
IUSE="cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2"
DEPEND="
- !sci-libs/libmaus
- >=sci-libs/io_lib-1.14.11
app-arch/snappy
sci-libs/fftw
sci-libs/hdf5
@@ -25,21 +23,20 @@ DEPEND="
dev-libs/nettle"
# --with-daligner
# --with-irods
-# old github.com release tarballs
-# S="${WORKDIR}"/libmaus2-master-27828cd78121d5e4b19c263c5527e462360f5901
-# current gitlab.com release tarballs
S="${WORKDIR}/${P}-release-${release_data}"
src_configure(){
local CONFIG_OPTS
use cpu_flags_x86_ssse3 && CONFIG_OPTS+=( --enable-ssse3 )
( use cpu_flags_x86_sse4_1 || use cpu_flags_x86_sse4_2 ) && CONFIG_OPTS+=( --enable-sse4 )
- econf --with-snappy --with-io_lib $CONFIG_OPTS \
+ econf --with-snappy $CONFIG_OPTS \
--with-lzma --with-gnutls --with-nettle --with-hdf5 --with-gmp --with-fftw
+ # --with-io_lib
+ # will require >=sci-libs/io_lib-1.14.11 which is not yet available in ::gentoo
}
pkg_postinst(){
- einfo "The io_lib, snappy dependencies are not strictly needed"
+ einfo "The snappy dependency is not strictly needed"
einfo "but were forced for optimal libmaus2 performance."
einfo "igzip is only used if gzip level is set to 11."
}
diff --git a/sci-libs/libmaus2/libmaus2-9999.ebuild b/sci-libs/libmaus2/libmaus2-9999.ebuild
index c371d5432..d2cbd9439 100644
--- a/sci-libs/libmaus2/libmaus2-9999.ebuild
+++ b/sci-libs/libmaus2/libmaus2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,8 +15,6 @@ KEYWORDS=""
IUSE="cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2"
DEPEND="
- !sci-libs/libmaus
- >=sci-libs/io_lib-1.14.11
app-arch/snappy
sci-libs/fftw
sci-libs/hdf5
@@ -34,12 +32,14 @@ src_configure(){
local CONFIG_OPTS
use cpu_flags_x86_ssse3 && CONFIG_OPTS+=( --enable-ssse3 )
( use cpu_flags_x86_sse4_1 || use cpu_flags_x86_sse4_2 ) && CONFIG_OPTS+=( --enable-sse4 )
- econf --with-snappy --with-io_lib $CONFIG_OPTS \
+ econf --with-snappy $CONFIG_OPTS \
--with-lzma --with-gnutls --with-nettle --with-hdf5 --with-gmp --with-fftw
+ # --with-io_lib
+ # will require >=sci-libs/io_lib-1.14.11 which is not yet available in ::gentoo
}
pkg_postinst(){
- einfo "The io_lib, snappy dependencies are not strictly needed"
+ einfo "The snappy dependency is not strictly needed"
einfo "but were forced for optimal libmaus2 performance."
einfo "igzip is only used if gzip level is set to 11."
}