aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan-Christofer Demay <jcdemay@gmail.com>2014-07-17 17:20:38 +0200
committerJonathan-Christofer Demay <jcdemay@gmail.com>2014-07-17 17:20:38 +0200
commit955e21c32bdccda0fec750c5376bf4fa5f8d4360 (patch)
tree0cd12a9bb0b15dd1aef596a4d614f42c60a28726 /sci-mathematics/apron/apron-0.9.10-r1.ebuild
parentfix make install/check (diff)
downloadsci-955e21c32bdccda0fec750c5376bf4fa5f8d4360.tar.gz
sci-955e21c32bdccda0fec750c5376bf4fa5f8d4360.tar.bz2
sci-955e21c32bdccda0fec750c5376bf4fa5f8d4360.zip
sci-mathematics/apron: force j1 for make
Diffstat (limited to 'sci-mathematics/apron/apron-0.9.10-r1.ebuild')
-rw-r--r--sci-mathematics/apron/apron-0.9.10-r1.ebuild11
1 files changed, 1 insertions, 10 deletions
diff --git a/sci-mathematics/apron/apron-0.9.10-r1.ebuild b/sci-mathematics/apron/apron-0.9.10-r1.ebuild
index 94180afd7..6cc45621d 100644
--- a/sci-mathematics/apron/apron-0.9.10-r1.ebuild
+++ b/sci-mathematics/apron/apron-0.9.10-r1.ebuild
@@ -54,12 +54,7 @@ src_prepare() {
}
src_compile() {
- #damn crappy Makefile
- emake || emake || die "emake failed"
-
- if use doc && use cxx; then
- emake -C apronxx doc || "emake doc failed"
- fi
+ emake -j1 || die "emake failed"
}
src_install(){
@@ -71,9 +66,5 @@ src_install(){
if use ocaml; then
dodoc mlapronidl/mlapronidl.pdf
fi
- if use cxx; then
- mv apronxx/doc/latex/refman.pdf apronxx/apronxx.pdf
- dodoc ./apronxx/apronxx.pdf
- fi
fi
}