aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/apron/apron-0.9.10-r1.ebuild')
-rw-r--r--sci-mathematics/apron/apron-0.9.10-r1.ebuild11
1 files changed, 1 insertions, 10 deletions
diff --git a/sci-mathematics/apron/apron-0.9.10-r1.ebuild b/sci-mathematics/apron/apron-0.9.10-r1.ebuild
index 94180afd7..6cc45621d 100644
--- a/sci-mathematics/apron/apron-0.9.10-r1.ebuild
+++ b/sci-mathematics/apron/apron-0.9.10-r1.ebuild
@@ -54,12 +54,7 @@ src_prepare() {
}
src_compile() {
- #damn crappy Makefile
- emake || emake || die "emake failed"
-
- if use doc && use cxx; then
- emake -C apronxx doc || "emake doc failed"
- fi
+ emake -j1 || die "emake failed"
}
src_install(){
@@ -71,9 +66,5 @@ src_install(){
if use ocaml; then
dodoc mlapronidl/mlapronidl.pdf
fi
- if use cxx; then
- mv apronxx/doc/latex/refman.pdf apronxx/apronxx.pdf
- dodoc ./apronxx/apronxx.pdf
- fi
fi
}