aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens-Malte Gottfried <jmgottfried@web.de>2012-03-07 00:08:49 +0100
committerJens-Malte Gottfried <jmgottfried@web.de>2012-03-07 00:08:49 +0100
commit2b3b883f45078a95cc0fc07f3cd9b2104575e6b5 (patch)
treea610ec1e78a833eb6384ecb3ace5d090759a472f /sci-mathematics
parentdisabled imagemagick, fixed lib configuring (diff)
downloadsci-2b3b883f45078a95cc0fc07f3cd9b2104575e6b5.tar.gz
sci-2b3b883f45078a95cc0fc07f3cd9b2104575e6b5.tar.bz2
sci-2b3b883f45078a95cc0fc07f3cd9b2104575e6b5.zip
fixed petsc 3.1 ebuild (missing patch files)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/petsc/ChangeLog5
-rw-r--r--sci-mathematics/petsc/files/petsc-3.1_p8-configure-pic.patch11
-rw-r--r--sci-mathematics/petsc/files/petsc-3.1_p8-disable-rpath.patch16
-rw-r--r--sci-mathematics/petsc/petsc-3.1_p8-r1.ebuild5
4 files changed, 35 insertions, 2 deletions
diff --git a/sci-mathematics/petsc/ChangeLog b/sci-mathematics/petsc/ChangeLog
index 5d1f4a953..4bc96b9bb 100644
--- a/sci-mathematics/petsc/ChangeLog
+++ b/sci-mathematics/petsc/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 06 Mar 2012; Jens-Malte Gottfried <jmgottfried@web.de>
+ petsc-3.1_p8-r1.ebuild, +files/petsc-3.1_p8-configure-pic.patch,
+ +files/petsc-3.1_p8-disable-rpath.patch:
+ fixed legacy ebuild of petsc 3.1
+
05 Mar 2012; Sébastien Fabbro <bicatali@gentoo.org> petsc-3.2_p6.ebuild,
+files/petsc-3.2_p6-configure-pic.patch,
+files/petsc-3.2_p6-disable-env-warnings.patch,
diff --git a/sci-mathematics/petsc/files/petsc-3.1_p8-configure-pic.patch b/sci-mathematics/petsc/files/petsc-3.1_p8-configure-pic.patch
new file mode 100644
index 000000000..bbfdae1c8
--- /dev/null
+++ b/sci-mathematics/petsc/files/petsc-3.1_p8-configure-pic.patch
@@ -0,0 +1,11 @@
+--- config/BuildSystem/config/setCompilers.py.old 2010-09-07 21:41:32.693103846 +0200
++++ config/BuildSystem/config/setCompilers.py 2010-09-07 21:41:45.322093881 +0200
+@@ -875,7 +875,7 @@
+ languages.append('FC')
+ for language in languages:
+ self.pushLanguage(language)
+- for testFlag in ['-PIC', '-fPIC', '-KPIC','-qpic']:
++ for testFlag in ['-fPIC', '-PIC', '-KPIC', '-qpic']:
+ try:
+ self.framework.logPrint('Trying '+language+' compiler flag '+testFlag)
+ if not self.checkLinkerFlag(testFlag):
diff --git a/sci-mathematics/petsc/files/petsc-3.1_p8-disable-rpath.patch b/sci-mathematics/petsc/files/petsc-3.1_p8-disable-rpath.patch
new file mode 100644
index 000000000..3c443b29f
--- /dev/null
+++ b/sci-mathematics/petsc/files/petsc-3.1_p8-disable-rpath.patch
@@ -0,0 +1,16 @@
+--- config/BuildSystem/config/setCompilers.py 2010-11-24 18:01:17.110124425 +0100
++++ config/BuildSystem/config/setCompilers.py 2010-11-24 18:02:28.710104226 +0100
+@@ -1186,12 +1186,7 @@
+ for language in languages:
+ flag = '-L'
+ self.pushLanguage(language)
+- # test '-R' before '-rpath' as sun compilers [c,fortran] don't give proper errors with wrong options.
+- if not Configure.isDarwin():
+- testFlags = ['-Wl,-rpath,', '-R','-rpath ' , '-Wl,-R,']
+- else:
+- testFlags = []
+- # test '-R' before '-Wl,-rpath' for SUN compilers [as cc on linux accepts -Wl,-rpath, but f90 & CC do not.
++ testFlags = []
+ if self.isSun(self.framework.getCompiler()):
+ testFlags.insert(0,'-R')
+ for testFlag in testFlags:
diff --git a/sci-mathematics/petsc/petsc-3.1_p8-r1.ebuild b/sci-mathematics/petsc/petsc-3.1_p8-r1.ebuild
index 5de7a8266..818cff185 100644
--- a/sci-mathematics/petsc/petsc-3.1_p8-r1.ebuild
+++ b/sci-mathematics/petsc/petsc-3.1_p8-r1.ebuild
@@ -37,8 +37,9 @@ if use hypre; then
fi
src_prepare(){
- epatch "${FILESDIR}/${PN}-configure-pic.patch"
- epatch "${FILESDIR}/${PN}-disable-rpath.patch"
+ epatch \
+ "${FILESDIR}"/${P}-configure-pic.patch \
+ "${FILESDIR}"/${P}-disable-rpath.patch
}
src_configure(){