aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens-Malte Gottfried <jmgottfried@web.de>2012-03-07 00:05:16 +0100
committerJens-Malte Gottfried <jmgottfried@web.de>2012-03-07 00:05:16 +0100
commitf7f2fd1f78ce27b03911c93c56ca6d56c1041225 (patch)
tree7d9fc9e1072b43de6a418cca226e85ffe28b380e /sci-mathematics
parentmoved comments out of the argument list (diff)
downloadsci-f7f2fd1f78ce27b03911c93c56ca6d56c1041225.tar.gz
sci-f7f2fd1f78ce27b03911c93c56ca6d56c1041225.tar.bz2
sci-f7f2fd1f78ce27b03911c93c56ca6d56c1041225.zip
disabled imagemagick, fixed lib configuring
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/petsc/petsc-3.2_p6.ebuild29
1 files changed, 19 insertions, 10 deletions
diff --git a/sci-mathematics/petsc/petsc-3.2_p6.ebuild b/sci-mathematics/petsc/petsc-3.2_p6.ebuild
index b1ea99f99..a3b11c414 100644
--- a/sci-mathematics/petsc/petsc-3.2_p6.ebuild
+++ b/sci-mathematics/petsc/petsc-3.2_p6.ebuild
@@ -16,8 +16,8 @@ LICENSE="petsc"
SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE="afterimage complex-scalars cxx debug doc
- fortran hdf5 hypre imagemagick metis mpi sparse superlu threads X"
-# Failed: boost
+ fortran hdf5 hypre metis mpi sparse superlu threads X"
+# Failed: boost imagemagick
# hypre and superlu curretly exclude each other due to missing linking to hypre
# if both are enabled
@@ -25,9 +25,9 @@ REQUIRED_USE="
hypre? ( cxx mpi )
hdf5? ( mpi )
afterimage? ( X )
- imagemagick? ( X )
^^ ( hypre superlu )
"
+# imagemagick? ( X )
RDEPEND="
virtual/blas
@@ -35,7 +35,6 @@ RDEPEND="
afterimage? ( media-libs/libafterimage )
hdf5? ( sci-libs/hdf5[mpi?] )
hypre? ( sci-libs/hypre[mpi?] )
- imagemagick? ( media-gfx/imagemagick )
metis? ( sci-libs/parmetis )
mpi? ( virtual/mpi[cxx?,fortran?] )
sparse? ( sci-libs/suitesparse >=sci-libs/cholmod-1.7.0 )
@@ -43,6 +42,7 @@ RDEPEND="
X? ( x11-libs/libX11 )
"
# boost? ( dev-libs/boost )
+# imagemagick? ( media-gfx/imagemagick )
DEPEND="${RDEPEND}
virtual/fortran
@@ -79,7 +79,7 @@ src_configure() {
if [[ $# -ge 4 ]]; then
myuse="${myuse} --with-${p}-include=${3}"
shift 3
- myuse="${myuse} --with-${p}-lib=\"$@\""
+ myuse="${myuse} --with-${p}-lib=$@"
else
myuse="${myuse} --with-${p}-dir=${EPREFIX}${3:-/usr}"
fi
@@ -135,21 +135,30 @@ src_configure() {
--with-windows-graphics=0 \
--with-matlab=0 \
--with-cmake=cmake \
- $(petsc_with afterimage afterimage /usr/include/libAfterImage -lAfterImage) \
+ $(petsc_with afterimage afterimage \
+ /usr/include/libAfterImage -lAfterImage) \
$(petsc_with hdf5) \
- $(petsc_with hypre hypre /usr/include/hypre -lHYPRE) \
- $(petsc_with imagemagick imagemagick /usr/include/ImageMagick $(pkg-config --libs MagickCore)) \
+ $(petsc_with hypre hypre \
+ /usr/include/hypre -lHYPRE) \
$(petsc_with metis parmetis) \
$(petsc_with sparse cholmod) \
- $(petsc_with superlu superlu /usr/include/superlu -lsuperlu) \
+ $(petsc_with superlu superlu \
+ /usr/include/superlu -lsuperlu) \
$(petsc_with X x) \
$(petsc_with X x11) \
+ --with-imagemagick=0 \
--with-python=0 \
--with-scotch=0
- # not yet tested: python bindings, sctotch support
+
+# not yet tested:
+# python bindings, sctotch, netcdf, scalapack
+# non-working:
+# fftw: no mpi-implementaion available in gentoo
# failed dependencies, perhaps fixed in upstream soon:
# $(petsc_with boost) \
+# $(petsc_with imagemagick imagemagick \
+# /usr/include/ImageMagick $(pkg-config --libs MagickCore)) \
}
src_install() {