aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Schmidt <das1993@hotmail.com>2014-08-09 09:38:15 +0200
committerDominik Schmidt <das1993@hotmail.com>2014-08-09 18:28:14 +0200
commita23eaf059583cee6d02e10fdd08e2c6e8a64d037 (patch)
tree06aea7675da9c1f90c1acecd3b1e4865c9dfacb4 /sci-mathematics
parentsci-mathematics/giac: Ebuild fix (diff)
downloadsci-a23eaf059583cee6d02e10fdd08e2c6e8a64d037.tar.gz
sci-a23eaf059583cee6d02e10fdd08e2c6e8a64d037.tar.bz2
sci-a23eaf059583cee6d02e10fdd08e2c6e8a64d037.zip
sci-mathematics/giac: Ebuild improvement
Added PAX-checks and exception for MPROTECT
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/giac/ChangeLog2
-rw-r--r--sci-mathematics/giac/giac-1.1.0.ebuild4
2 files changed, 4 insertions, 2 deletions
diff --git a/sci-mathematics/giac/ChangeLog b/sci-mathematics/giac/ChangeLog
index 40d2c71bf..ee8f67716 100644
--- a/sci-mathematics/giac/ChangeLog
+++ b/sci-mathematics/giac/ChangeLog
@@ -3,7 +3,7 @@
# $Header: $
09 Aug 2014; Dominik Schmidt <das1993@hotmail.com>
- Fixed fltk handling
+ Fixed fltk handling, added PAX-checks and exception.
21 Jun 2014; Jonathan-Christofer Demay <jcdemay@gmail.com>
-giac-1.0.0.ebuild, +giac-1.1.0.ebuild:
diff --git a/sci-mathematics/giac/giac-1.1.0.ebuild b/sci-mathematics/giac/giac-1.1.0.ebuild
index 4993db4f7..467215ad8 100644
--- a/sci-mathematics/giac/giac-1.1.0.ebuild
+++ b/sci-mathematics/giac/giac-1.1.0.ebuild
@@ -14,7 +14,7 @@ KEYWORDS="~x86 ~amd64"
IUSE="doc examples fltk"
AUTOTOOLS_IN_SOURCE_BUILD=true
-inherit autotools-utils flag-o-matic
+inherit autotools-utils flag-o-matic pax-utils
RDEPEND=">=dev-libs/gmp-3
>=sys-libs/readline-4.2
@@ -55,6 +55,8 @@ src_install() {
dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README TROUBLES
if use !fltk; then
rm ${D}/usr/bin/x*
+ elif host-is-pax; then
+ pax-mark -m ${D}/usr/bin/x*
fi
if use !doc; then
rm -R ${D}/usr/share/doc/giac ${D}/usr/share/giac/doc/