aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens-Malte Gottfried <jmgottfried@web.de>2012-03-05 17:10:46 +0100
committerJens-Malte Gottfried <jmgottfried@web.de>2012-03-05 17:10:46 +0100
commita4f4b83914fec669a8c3684551a8a5b2bb721a12 (patch)
tree4688ad1d81664f092be241a301987849718d56b8 /sci-mathematics
parentadded superlu on activated hypre flag (diff)
downloadsci-a4f4b83914fec669a8c3684551a8a5b2bb721a12.tar.gz
sci-a4f4b83914fec669a8c3684551a8a5b2bb721a12.tar.bz2
sci-a4f4b83914fec669a8c3684551a8a5b2bb721a12.zip
fix missing linking if hypre and superlu enabled
this is a workaround, perhaps this problem will be fixed in upstream
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/petsc/metadata.xml3
-rw-r--r--sci-mathematics/petsc/petsc-3.2_p6.ebuild10
2 files changed, 9 insertions, 4 deletions
diff --git a/sci-mathematics/petsc/metadata.xml b/sci-mathematics/petsc/metadata.xml
index 10bb79f90..f0f9f1889 100644
--- a/sci-mathematics/petsc/metadata.xml
+++ b/sci-mathematics/petsc/metadata.xml
@@ -4,10 +4,11 @@
<herd>sci-mathematics</herd>
<use>
<flag name="afterimage">Use Afterstep image library (media-libs/libafterimage)</flag>
- <flag name="hypre">Use HYPRE (sci-mathematics/hypre) and superlu (sci-libs/superlu) for preconditioning</flag>
+ <flag name="hypre">Use HYPRE (sci-mathematics/hypre) and for preconditioning</flag>
<flag name="metis">Use METIS (sci-libs/parmetis) for partitioning</flag>
<flag name="complex-scalars">Make scalars complex</flag>
<flag name="sparse">Use suitesparse (sci-libs/suitesparse) including cholmod (sci-libs/cholmod) for sparse factorization</flag>
+ <flag name="superlu">Use superlu (sci-libs/superlu) for preconditioning</flag>
<!-- Disabled:
<flag name="boost">Use boost (dev-libs/boost)</flag>
-->
diff --git a/sci-mathematics/petsc/petsc-3.2_p6.ebuild b/sci-mathematics/petsc/petsc-3.2_p6.ebuild
index 23dc7cad0..5426f692a 100644
--- a/sci-mathematics/petsc/petsc-3.2_p6.ebuild
+++ b/sci-mathematics/petsc/petsc-3.2_p6.ebuild
@@ -16,13 +16,16 @@ LICENSE="petsc"
SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE="afterimage complex-scalars cxx debug doc \
- fortran hdf5 hypre metis mpi sparse threads X"
+ fortran hdf5 hypre metis mpi sparse superlu threads X"
# Failed: boost imagemagick
+# hypre and superlu curretly exclude each other due to missing linking to hypre
+# if both are enabled
REQUIRED_USE="
hypre? ( cxx mpi )
hdf5? ( mpi )
afterimage? ( X )
+ ^^ ( hypre superlu )
"
# imagemagick? ( X )
@@ -30,11 +33,12 @@ RDEPEND="mpi? ( virtual/mpi[cxx?,fortran?] )
X? ( x11-libs/libX11 )
virtual/lapack
virtual/blas
- hypre? ( sci-libs/hypre sci-libs/superlu )
+ hypre? ( sci-libs/hypre )
metis? ( sci-libs/parmetis )
hdf5? ( sci-libs/hdf5 )
afterimage? ( media-libs/libafterimage )
sparse? ( sci-libs/suitesparse >=sci-libs/cholmod-1.7.0 )
+ superlu? ( sci-libs/superlu )
"
# boost? ( dev-libs/boost )
# imagemagick? ( media-gfx/imagemagick )
@@ -128,9 +132,9 @@ src_configure(){
/usr/$(get_libdir)/libAfterImage.so /usr/include/libAfterImage) \
$(petsc_with hdf5) \
$(petsc_with hypre hypre /usr/$(get_libdir)/libHYPRE.so /usr/include/hypre) \
- $(petsc_with hypre superlu /usr/$(get_libdir)/libsuperlu.so /usr/include/superlu) \
$(petsc_with metis parmetis) \
$(petsc_with sparse cholmod) \
+ $(petsc_with superlu superlu /usr/$(get_libdir)/libsuperlu.so /usr/include/superlu) \
$(petsc_with X x) \
$(petsc_with X x11) \
--with-scotch=0