aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlammie Pirinen <flammie@gentoo.org>2011-05-09 19:39:54 +0300
committerFlammie Pirinen <flammie@gentoo.org>2011-05-09 19:39:54 +0300
commit9155f92d59b603acf3c3b3c03b65dc9327381f7e (patch)
tree9cef789a0d6082b010a9d1aa3d3c012a43cbe616 /sci-misc/openfst/openfst-1.2.7.ebuild
parentRemove old ebuilds since the sources have disappeared (diff)
downloadsci-9155f92d59b603acf3c3b3c03b65dc9327381f7e.tar.gz
sci-9155f92d59b603acf3c3b3c03b65dc9327381f7e.tar.bz2
sci-9155f92d59b603acf3c3b3c03b65dc9327381f7e.zip
Version bump
Diffstat (limited to 'sci-misc/openfst/openfst-1.2.7.ebuild')
-rw-r--r--sci-misc/openfst/openfst-1.2.7.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-misc/openfst/openfst-1.2.7.ebuild b/sci-misc/openfst/openfst-1.2.7.ebuild
new file mode 100644
index 000000000..4ccb69f2c
--- /dev/null
+++ b/sci-misc/openfst/openfst-1.2.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils multilib flag-o-matic
+
+DESCRIPTION="Finite State Transducer tools by Google et al."
+HOMEPAGE="http://www.openfst.org"
+SRC_URI="http://www.openfst.org/twiki/pub/FST/FstDownload/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ filter-ldflags -Wl,--as-needed --as-needed
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS NEWS README || die "docs missing"
+}
+
+src_test() {
+ einfo "make test can take a few hours on moderately modern systems"
+ make test || die "check failed"
+}