aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Horel <guillaume.horel@gmail.com>2012-08-04 13:02:39 -0400
committerGuillaume Horel <guillaume.horel@gmail.com>2012-08-04 13:02:39 -0400
commit33b466cc034c7d9fea2ee8f0cc977ef711046aa9 (patch)
treee3eb121a877ffd5c6d3f59d7ef794052e00688ed /sci-misc/openfst/openfst-1.3.2.ebuild
parentdev-ml/lacaml version bump and cleanup old version (diff)
parentscotch in main tree (diff)
downloadsci-33b466cc034c7d9fea2ee8f0cc977ef711046aa9.tar.gz
sci-33b466cc034c7d9fea2ee8f0cc977ef711046aa9.tar.bz2
sci-33b466cc034c7d9fea2ee8f0cc977ef711046aa9.zip
dev-java/scirenderer version bump
Diffstat (limited to 'sci-misc/openfst/openfst-1.3.2.ebuild')
-rw-r--r--sci-misc/openfst/openfst-1.3.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-misc/openfst/openfst-1.3.2.ebuild b/sci-misc/openfst/openfst-1.3.2.ebuild
new file mode 100644
index 000000000..98cbaa76e
--- /dev/null
+++ b/sci-misc/openfst/openfst-1.3.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="Finite State Transducer tools by Google et al."
+HOMEPAGE="http://www.openfst.org"
+SRC_URI="http://www.openfst.org/twiki/pub/FST/FstDownload/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS NEWS README || die "docs missing"
+}
+
+src_test() {
+ einfo "make test can take a few hours on moderately modern systems"
+ make test || die "check failed"
+}