aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2014-04-03 08:35:21 -0700
committerSébastien Fabbro <bicatali@gentoo.org>2014-04-03 08:35:21 -0700
commit87028c6d48207335e42580890a6229ab2981bd71 (patch)
tree9b77b2892515bd93f64d076ec010e60b5aec52ba /sci-physics/genfit/genfit-02.00.00.ebuild
parentMerge pull request #215 from olifre/fix-sf-zip-snapshots (diff)
downloadsci-87028c6d48207335e42580890a6229ab2981bd71.tar.gz
sci-87028c6d48207335e42580890a6229ab2981bd71.tar.bz2
sci-87028c6d48207335e42580890a6229ab2981bd71.zip
Link fixed version ebuild to live one, add no keyword to live version
Diffstat (limited to 'sci-physics/genfit/genfit-02.00.00.ebuild')
l---------[-rw-r--r--]sci-physics/genfit/genfit-02.00.00.ebuild60
1 files changed, 1 insertions, 59 deletions
diff --git a/sci-physics/genfit/genfit-02.00.00.ebuild b/sci-physics/genfit/genfit-02.00.00.ebuild
index 5e095a52f..c4f24f2cb 100644..120000
--- a/sci-physics/genfit/genfit-02.00.00.ebuild
+++ b/sci-physics/genfit/genfit-02.00.00.ebuild
@@ -1,59 +1 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-inherit cmake-utils versionator
-
-if [[ ${PV} == *9999* ]]; then
- inherit subversion
- ESVN_REPO_URI="https://svn.code.sf.net/p/${PN}/code/trunk"
- ESVN_PROJECT="${PN}.${PV}"
-else
- # .zip-snapshot can be recreated by visiting
- # http://sourceforge.net/p/${PN}/code/${COMMIT}/tarball?path=/tags/v$(replace_all_version_separators '-')
- TAG_VER=${PN}-code-1688-tags-v$(replace_all_version_separators '-')
- #SRC_URI="http://sourceforge.net/code-snapshots/svn/g/ge/genfit/code/${TAG_VER}.zip"
- SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${TAG_VER}.zip"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
- S=${WORKDIR}/${TAG_VER}
-fi
-
-DESCRIPTION="a generic toolkit for track reconstruction for experiments in particle and nuclear physics"
-HOMEPAGE="http://genfit.sourceforge.net/Main.html"
-
-LICENSE="LGPL-3"
-SLOT="0"
-IUSE="doc examples"
-
-RDEPEND="
- sci-physics/root:=
- dev-libs/boost:="
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen[dot] )"
-
-src_compile() {
- cmake-utils_src_compile
- use doc && cmake-utils_src_compile doc
- use examples && cmake-utils_src_compile tests
-}
-
-src_install() {
- cmake-utils_src_install
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r "${BUILD_DIR}/bin"
- doins "${S}/test/makeGeom.C"
- doins "${S}/test/README"
- fi
- cd doc || die
- use doc && dohtml -r "${S}/doc/html/"*
- echo
- elog "Note that there is no support in this ebuild for RAVE yet,"
- elog "which is also not in portage."
- elog "It should be possible to use a local installation of RAVE"
- elog "and set:"
- elog " export RAVEPATH=<yourRaveDirectory>"
- echo
-}
+genfit-9999.ebuild \ No newline at end of file