aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gmail.com>2012-10-20 01:31:37 +0400
committerAndrew Savchenko <bircoph@gmail.com>2012-10-20 01:31:37 +0400
commitad450b5a8244258f75e1db6030e51b437129cee8 (patch)
tree0b12f56a58069d18615f5587c65d5ecd52401d04 /sci-physics/root/files
parentopenbabel-python: Fix typo (diff)
downloadsci-ad450b5a8244258f75e1db6030e51b437129cee8.tar.gz
sci-ad450b5a8244258f75e1db6030e51b437129cee8.tar.bz2
sci-ad450b5a8244258f75e1db6030e51b437129cee8.zip
sci-physics/root: version bump
Version bump in 5.32 and 5.34 branches.
Diffstat (limited to 'sci-physics/root/files')
-rw-r--r--sci-physics/root/files/root-5.28.00b-asneeded.patch20
-rw-r--r--sci-physics/root/files/root-5.28.00b-nobyte-compile.patch138
-rw-r--r--sci-physics/root/files/root-5.28.00h-explicit-functions.patch12
-rw-r--r--sci-physics/root/files/root-5.32.00-dotfont.patch58
-rw-r--r--sci-physics/root/files/root-5.32.00-explicit-functions.patch18
-rw-r--r--sci-physics/root/files/root-5.34.01-glibc216.patch35
6 files changed, 281 insertions, 0 deletions
diff --git a/sci-physics/root/files/root-5.28.00b-asneeded.patch b/sci-physics/root/files/root-5.28.00b-asneeded.patch
new file mode 100644
index 000000000..b845247e1
--- /dev/null
+++ b/sci-physics/root/files/root-5.28.00b-asneeded.patch
@@ -0,0 +1,20 @@
+--- root.orig/configure 2010-12-20 07:17:54.000000000 +0000
++++ root/configure 2010-12-20 07:16:05.000000000 +0000
+@@ -709,7 +709,7 @@
+ cat <<EOF > conftest.mk
+ include ${ac_srcdir}/config/Makefile.${arch}
+ conftest: conftest.c
+- \$(CC) \$(CFLAGS) \$(LDFLAGS) $linkdir $linklib \$< -o \$@
++ \$(CC) \$(CFLAGS) \$(LDFLAGS) \$< $linkdir $linklib -o \$@
+
+ conftest.c:
+ echo "int main() { return 0; }" > \$@
+@@ -723,7 +723,7 @@
+ cat <<EOF > conftest.mk
+ include ${ac_srcdir}/config/Makefile.${arch}
+ conftest:conftest.c
+- \$(CC) \$(CFLAGS) \$(LDFLAGS) $linkdir $linklib \$< -o \$@
++ \$(CC) \$(CFLAGS) \$(LDFLAGS) \$< $linkdir $linklib -o \$@
+
+ conftest.c:
+ echo "extern int $linksymbol (); " > \$@
diff --git a/sci-physics/root/files/root-5.28.00b-nobyte-compile.patch b/sci-physics/root/files/root-5.28.00b-nobyte-compile.patch
new file mode 100644
index 000000000..7029bf169
--- /dev/null
+++ b/sci-physics/root/files/root-5.28.00b-nobyte-compile.patch
@@ -0,0 +1,138 @@
+diff -Naur root.orig/Makefile root/Makefile
+--- root.orig/Makefile 2010-12-17 22:48:40.577775091 +0300
++++ root/Makefile 2010-12-17 22:49:27.902497903 +0300
+@@ -1148,10 +1148,7 @@
+ if test "x$(RFLX_GRFLXPY)" != "x"; then \
+ rm -f $(DESTDIR)$(LIBDIR)/$(RFLX_GRFLXPY); \
+ fi; \
+- if test "x$(RFLX_GRFLXPYC)" != "x"; then \
+- rm -f $(DESTDIR)$(LIBDIR)/$(RFLX_GRFLXPYC); \
+- fi; \
+- if test "x$(RFLX_GRFLXPY)$(RFLX_GRFLXPYC)" != "x"; then \
++ if test "x$(RFLX_GRFLXPY)" != "x"; then \
+ dir=$(RFLX_GRFLXDD:lib/=); \
+ while test "x$${dir}" != "x" && \
+ test -d $(DESTDIR)$(LIBDIR)/$${dir} && \
+diff -Naur root.orig/bindings/pyroot/Module.mk root/bindings/pyroot/Module.mk
+--- root.orig/bindings/pyroot/Module.mk 2010-12-17 22:48:39.941179413 +0300
++++ root/bindings/pyroot/Module.mk 2010-12-17 22:49:27.899164943 +0300
+@@ -48,8 +48,6 @@
+ ROOTPY := $(subst $(MODDIR),$(LPATH),$(ROOTPYS))
+ $(LPATH)/%.py: $(MODDIR)/%.py; cp $< $@
+ endif
+-ROOTPYC := $(ROOTPY:.py=.pyc)
+-ROOTPYO := $(ROOTPY:.py=.pyo)
+
+ # used in the main Makefile
+ ALLHDRS += $(patsubst $(MODDIRI)/%.h,include/%.h,$(PYROOTH))
+@@ -68,10 +66,8 @@
+ include/%.h: $(PYROOTDIRI)/%.h
+ cp $< $@
+
+-%.pyc: %.py; python -c 'import py_compile; py_compile.compile( "$<" )'
+-%.pyo: %.py; python -O -c 'import py_compile; py_compile.compile( "$<" )'
+
+-$(PYROOTLIB): $(PYROOTO) $(PYROOTDO) $(ROOTPY) $(ROOTPYC) $(ROOTPYO) \
++$(PYROOTLIB): $(PYROOTO) $(PYROOTDO) $(ROOTPY) \
+ $(ROOTLIBSDEP) $(PYTHONLIBDEP)
+ @$(MAKELIB) $(PLATFORM) $(LD) "$(LDFLAGS)" \
+ "$(SOFLAGS)" libPyROOT.$(SOEXT) $@ \
+@@ -113,7 +109,7 @@
+
+ distclean-$(MODNAME): clean-$(MODNAME)
+ @rm -f $(PYROOTDEP) $(PYROOTDS) $(PYROOTDH) $(PYROOTLIB) \
+- $(ROOTPY) $(ROOTPYC) $(ROOTPYO) $(PYROOTMAP) \
++ $(ROOTPY) $(PYROOTMAP) \
+ $(PYROOTPYD) $(PYTHON64DEP) $(PYTHON64)
+
+ distclean:: distclean-$(MODNAME)
+diff -Naur root.orig/build/package/debian/rules root/build/package/debian/rules
+--- root.orig/build/package/debian/rules 2010-12-17 22:48:40.197817461 +0300
++++ root/build/package/debian/rules 2010-12-17 22:49:27.902497903 +0300
+@@ -623,10 +623,6 @@
+ -X$(SYSCONFDIR)/root/system.rootauthrc \
+ -X$(SYSCONFDIR)/root/system.rootdaemonrc \
+ -X$(PREFIX)/lib/root/$(SOVERS)/libAfterImage.a \
+- -X$(PREFIX)/lib/root/$(SOVERS)/PyCintex.pyc \
+- -X$(PREFIX)/lib/root/$(SOVERS)/PyCintex.pyo \
+- -X$(PREFIX)/lib/root/$(SOVERS)/ROOT.pyc \
+- -X$(PREFIX)/lib/root/$(SOVERS)/ROOT.pyo
+ # $(foreach i, \
+ # $(wildcard $(DTMP)/$(PREFIX)/lib/root/lib*.so.$(SOVERS)), \
+ # -X$(i:$(DTMP)/%=%) )
+diff -Naur root.orig/cint/cintex/Module.mk root/cint/cintex/Module.mk
+--- root.orig/cint/cintex/Module.mk 2010-12-17 22:48:40.057833071 +0300
++++ root/cint/cintex/Module.mk 2010-12-17 22:49:27.902497903 +0300
+@@ -31,10 +31,6 @@
+ CINTEXPY := $(subst $(MODDIR)/python,$(LPATH),$(CINTEXPYS))
+ $(LPATH)/%.py: $(MODDIR)/python/%.py; cp $< $@
+ endif
+-ifneq ($(BUILDPYTHON),no)
+-CINTEXPYC := $(CINTEXPY:.py=.pyc)
+-CINTEXPYO := $(CINTEXPY:.py=.pyo)
+-endif
+
+ # used in the main Makefile
+ ALLHDRS += $(patsubst $(MODDIRI)/Cintex/%.h,include/Cintex/%.h,$(CINTEXH))
+@@ -86,8 +82,6 @@
+ fi)
+ cp $< $@
+
+-%.pyc: %.py; python -c 'import py_compile; py_compile.compile( "$<" )'
+-%.pyo: %.py; python -O -c 'import py_compile; py_compile.compile( "$<" )'
+
+ $(CINTEXLIB): $(CINTEXO) $(CINTEXPY) $(CINTEXPYC) $(CINTEXPYO) \
+ $(ORDER_) $(subst $(CINTEXLIB),,$(MAINLIBS)) $(CINTEXLIBDEP)
+diff -Naur root.orig/cint/reflex/Module.mk root/cint/reflex/Module.mk
+--- root.orig/cint/reflex/Module.mk 2010-12-17 22:48:40.037835301 +0300
++++ root/cint/reflex/Module.mk 2010-12-17 22:51:36.871451359 +0300
+@@ -48,9 +48,6 @@
+ RFLX_GRFLXS := $(wildcard $(RFLX_GRFLXSD)/*.py)
+ RFLX_GRFLXPY := $(patsubst $(RFLX_GRFLXSD)/%.py,$(RFLX_GRFLXDD)/%.py,$(RFLX_GRFLXS))
+ RFLX_GRFLXPY += $(RFLX_GCCXMLPATHPY)
+-ifneq ($(BUILDPYTHON),no)
+-RFLX_GRFLXPYC := $(subst .py,.pyc,$(RFLX_GRFLXPY))
+-endif
+
+ RFLX_LIBDIR = $(LIBDIR)
+
+@@ -92,7 +89,7 @@
+
+ ALLEXECS += $(RFLX_GENMAPX)
+
+-POSTBIN += $(RFLX_GRFLXPYC) $(RFLX_GRFLXPY)
++POSTBIN += $(RFLX_GRFLXPY)
+
+ ##### local rules #####
+ .PHONY: all-$(MODNAME) clean-$(MODNAME) distclean-$(MODNAME) \
+@@ -122,8 +119,6 @@
+ mkdir -p lib/python/genreflex; fi )
+ cp $< $@
+
+-$(RFLX_GRFLXDD)/%.pyc: $(RFLX_GRFLXDD)/%.py
+- @python -c 'import py_compile; py_compile.compile( "$<" )'
+
+ $(RFLX_GENMAPO) : CXXFLAGS += -I$(REFLEXDIRS)/genmap
+
+@@ -149,7 +144,7 @@
+ $(RLIBMAP) -o $@ -l $(REFLEXDICTLIB) \
+ -d $(REFLEXDICTLIBDEPM) -c $(REFLEXL)
+
+-all-$(MODNAME): $(REFLEXLIB) $(REFLEXDICTLIB) $(REFLEXDICTMAP) $(RFLX_GRFLXPYC) $(RFLX_GRFLXPY)
++all-$(MODNAME): $(REFLEXLIB) $(REFLEXDICTLIB) $(REFLEXDICTMAP) $(RFLX_GRFLXPY)
+
+ clean-genreflex:
+ @rm -rf lib/python/genreflex
+diff -Naur root.orig/cint/reflex/python/CMakeLists.txt root/cint/reflex/python/CMakeLists.txt
+--- root.orig/cint/reflex/python/CMakeLists.txt 2010-12-17 22:48:40.037835301 +0300
++++ root/cint/reflex/python/CMakeLists.txt 2010-12-17 22:49:27.902497903 +0300
+@@ -15,7 +15,7 @@
+ ##################### sources ####################
+
+ FILE(GLOB_RECURSE GENREFLEX_SRCS RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} genreflex/*.py)
+-SET(GENREFLEX_SCRIPT ${CMAKE_CURRENT_BINARY_DIR}/genreflex/genreflex.pyc PARENT_SCOPE)
++SET(GENREFLEX_SCRIPT PARENT_SCOPE)
+
+ ##################### gccxmlpath ####################
+
+
diff --git a/sci-physics/root/files/root-5.28.00h-explicit-functions.patch b/sci-physics/root/files/root-5.28.00h-explicit-functions.patch
new file mode 100644
index 000000000..918b696cb
--- /dev/null
+++ b/sci-physics/root/files/root-5.28.00h-explicit-functions.patch
@@ -0,0 +1,12 @@
+--- root/io/io/Module.mk.orig 2011-11-24 20:12:56.000000000 +0400
++++ root/io/io/Module.mk 2012-03-09 03:45:42.850549826 +0400
+@@ -67,9 +67,4 @@
+ distclean:: distclean-$(MODNAME)
+
+ ##### extra rules ######
+-#ifeq ($(GCC_VERS_FULL),gcc-4.4.0)
+-ifeq ($(GCC_VERS),gcc-4.4)
+-ifneq ($(filter -O%,$(OPT)),)
+ $(call stripsrc,$(IODIRS)/TStreamerInfoReadBuffer.o): CXXFLAGS += -DR__EXPLICIT_FUNCTION_INSTANTIATION
+-endif
+-endif
diff --git a/sci-physics/root/files/root-5.32.00-dotfont.patch b/sci-physics/root/files/root-5.32.00-dotfont.patch
new file mode 100644
index 000000000..85d6dea76
--- /dev/null
+++ b/sci-physics/root/files/root-5.32.00-dotfont.patch
@@ -0,0 +1,58 @@
+--- root/html/src/TClassDocOutput.cxx.orig 2012-05-25 16:18:10.000000000 +0400
++++ root/html/src/TClassDocOutput.cxx 2012-05-29 21:36:53.813593012 +0400
+@@ -625,7 +625,7 @@
+ << "size=\"8,10\";" << endl
+ << "ratio=auto;" << endl
+ << "margin=0;" << endl
+- << "node [shape=plaintext,fontsize=40,width=4,height=0.75];" << endl
++ << "node [shape=plaintext,fontsize=40,width=4,height=0.75,fontname=\"DejaVu Serif\"];" << endl
+ << "\"" << fCurrentClass->GetName() << "\" [shape=ellipse];" << endl;
+
+ std::stringstream ssDep;
+@@ -704,7 +704,7 @@
+ outdot << ";" << endl;
+ } else if (writeAndMoreFor) {
+ outdot << " \"...andmore" << writeAndMoreFor->GetName()
+- << "\" [label=\"...and more\",fontname=\"Times-Italic\",fillcolor=lightgrey,style=filled];" << endl;
++ << "\" [label=\"...and more\",fontname=\"DejaVu Serif Italic\",fillcolor=lightgrey,style=filled];" << endl;
+ }
+ }
+ if (!levelExists) break;
+@@ -733,7 +733,7 @@
+ << "ranksep=0.1;" << endl
+ << "nodesep=0;" << endl
+ << "margin=0;" << endl;
+- outdot << " node [style=filled,width=0.7,height=0.15,fixedsize=true,shape=plaintext,fontsize=10];" << endl;
++ outdot << " node [style=filled,width=0.7,height=0.15,fixedsize=true,shape=plaintext,fontsize=10,fontname=\"DejaVu Serif\"];" << endl;
+
+ std::stringstream ssDep;
+ const int numColumns = 3;
+@@ -939,7 +939,7 @@
+ << "ranksep=0;" << endl
+ << "nodesep=0;" << endl
+ << "size=\"8,10\";" << endl
+- << "node [fontsize=20,shape=plaintext];" << endl;
++ << "node [fontsize=20,shape=plaintext,fontname=\"DejaVu Serif\"];" << endl;
+
+ for (std::list<std::string>::iterator iFile = listFilesToParse.begin();
+ iFile != listFilesToParse.end(); ++iFile) {
+@@ -999,7 +999,8 @@
+ << "ranksep=0.7;" << endl
+ << "nodesep=0.3;" << endl
+ << "size=\"8,8\";" << endl
+- << "ratio=compress;" << endl;
++ << "ratio=compress;" << endl
++ << "node [fontname=\"DejaVu Serif\"];" << endl;
+
+ TString libs(fCurrentClass->GetSharedLibs());
+ outdot << "\"All Libraries\" [URL=\"LibraryDependencies.html\",shape=box,rank=max,fillcolor=lightgray,style=filled];" << endl;
+@@ -1109,7 +1110,8 @@
+
+ dotout << "digraph G {" << endl
+ << "ratio=auto;" << endl
+- << "rankdir=RL;" << endl;
++ << "rankdir=RL;" << endl
++ << "node [fontname=\"DejaVu Serif\"];" << endl;
+
+ // loop on all classes
+ TClassDocInfo* cdi = 0;
diff --git a/sci-physics/root/files/root-5.32.00-explicit-functions.patch b/sci-physics/root/files/root-5.32.00-explicit-functions.patch
new file mode 100644
index 000000000..570d61e68
--- /dev/null
+++ b/sci-physics/root/files/root-5.32.00-explicit-functions.patch
@@ -0,0 +1,18 @@
+--- root/io/io/Module.mk.orig 2012-02-29 19:46:38.000000000 +0400
++++ root/io/io/Module.mk 2012-03-09 02:29:19.905665572 +0400
+@@ -67,15 +67,5 @@
+ distclean:: distclean-$(MODNAME)
+
+ ##### extra rules ######
+-#ifeq ($(GCC_VERS_FULL),gcc-4.4.0)
+-ifeq ($(GCC_VERS),gcc-4.4)
+-ifneq ($(filter -O%,$(OPT)),)
+ $(call stripsrc,$(IODIRS)/TStreamerInfoReadBuffer.o): CXXFLAGS += -DR__EXPLICIT_FUNCTION_INSTANTIATION
+-endif
+-endif
+-ifeq ($(GCC_VERS),gcc-4.5)
+-ifneq ($(filter -O%,$(OPT)),)
+ $(call stripsrc,$(IODIRS)/TStreamerInfoReadBuffer.o): CXXFLAGS += -DR__EXPLICIT_FUNCTION_INSTANTIATION
+-endif
+-endif
+-
diff --git a/sci-physics/root/files/root-5.34.01-glibc216.patch b/sci-physics/root/files/root-5.34.01-glibc216.patch
new file mode 100644
index 000000000..b2da15970
--- /dev/null
+++ b/sci-physics/root/files/root-5.34.01-glibc216.patch
@@ -0,0 +1,35 @@
+diff -ur root-5.34.00.orig/build/rmkdepend/main.c root-5.34.00/build/rmkdepend/main.c
+--- root-5.34.00.orig/build/rmkdepend/main.c 2012-06-05 15:31:46.000000000 +0200
++++ root-5.34.00/build/rmkdepend/main.c 2012-07-05 20:42:58.938953353 +0200
+@@ -60,7 +60,7 @@
+ # endif
+ # elif defined(__CYGWIN__)
+ extern int fchmod(int, mode_t);
+-#else
++# elif !defined(__GLIBC__) || __GLIBC__ < 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ < 16)
+ extern int fchmod(int, int);
+ # endif
+ #endif
+diff -ur root-5.34.00.orig/cint/tool/rmkdepend/main.c root-5.34.00/cint/tool/rmkdepend/main.c
+--- root-5.34.00.orig/cint/tool/rmkdepend/main.c 2012-06-05 15:31:30.000000000 +0200
++++ root-5.34.00/cint/tool/rmkdepend/main.c 2012-07-05 20:42:58.492949104 +0200
+@@ -58,7 +58,7 @@
+ #if !defined(MAC_OS_X_VERSION_10_4)
+ extern int fchmod();
+ #endif
+-#else
++#elif !defined(__GLIBC__) || __GLIBC__ < 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ < 16)
+ extern int fchmod();
+ #endif
+ #endif
+diff -ur root-5.34.00.orig/core/unix/src/TUnixSystem.cxx root-5.34.00/core/unix/src/TUnixSystem.cxx
+--- root-5.34.00.orig/core/unix/src/TUnixSystem.cxx 2012-06-05 15:31:17.000000000 +0200
++++ root-5.34.00/core/unix/src/TUnixSystem.cxx 2012-07-05 20:29:29.969242837 +0200
+@@ -98,6 +98,7 @@
+ #include <pwd.h>
+ #include <grp.h>
+ #include <errno.h>
++#include <sys/resource.h>
+ #include <sys/wait.h>
+ #include <time.h>
+ #include <sys/time.h>