aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Kerr <cjk34@cam.ac.uk>2013-06-15 15:46:32 +0100
committerChris Kerr <cjk34@cam.ac.uk>2013-06-15 15:46:32 +0100
commit60620770d00065f0867992724aeb54ff80a51aa8 (patch)
tree464a8fd3715fd952c87b56898dcc26d058996825 /sys-cluster/htcondor/htcondor-8.0.0.ebuild
parentCreated htcondor-8.0.0.ebuild (diff)
downloadsci-60620770d00065f0867992724aeb54ff80a51aa8.tar.gz
sci-60620770d00065f0867992724aeb54ff80a51aa8.tar.bz2
sci-60620770d00065f0867992724aeb54ff80a51aa8.zip
Created manifest
Diffstat (limited to 'sys-cluster/htcondor/htcondor-8.0.0.ebuild')
-rw-r--r--sys-cluster/htcondor/htcondor-8.0.0.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sys-cluster/htcondor/htcondor-8.0.0.ebuild b/sys-cluster/htcondor/htcondor-8.0.0.ebuild
index cadcfdbd3..4550fc081 100644
--- a/sys-cluster/htcondor/htcondor-8.0.0.ebuild
+++ b/sys-cluster/htcondor/htcondor-8.0.0.ebuild
@@ -5,7 +5,7 @@
EAPI=5
PYTHON_COMPAT=( python{2_5,2_6,2_7} )
-inherit cmake-utils python-r1 python-single-r1
+inherit cmake-utils python-single-r1
DESCRIPTION="Workload management system for compute-intensive jobs"
HOMEPAGE="http://www.cs.wisc.edu/htcondor/"
@@ -42,6 +42,11 @@ RESTRICT=fetch
S="${WORKDIR}/condor-${PV}"
+pkg_setup() {
+ enewgroup condor
+ enewuser condor -1 "${ROOT}"bin/bash "${ROOT}var/lib/condor" condor
+}
+
src_configure() {
local mycmakeargs="
$(cmake-utils_use_have boinc backfill)
@@ -60,4 +65,4 @@ src_configure() {
$(cmake-utils_use_with ssl openssl)
$(cmake-utils_use_with xml libxml2)"
cmake-utils_src_configure
-} \ No newline at end of file
+}