aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/clfft/Manifest1
-rw-r--r--sci-libs/clfft/clfft-2.12.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/sci-libs/clfft/Manifest b/sci-libs/clfft/Manifest
index 93018a3e0..3accf6a29 100644
--- a/sci-libs/clfft/Manifest
+++ b/sci-libs/clfft/Manifest
@@ -1,2 +1,3 @@
DIST clfft-2.10.0.tar.gz 986031 SHA256 f70d8ae7b8c38f27b4f28e5e7abe55378e18c4f1c5cf8922b561dc908d36ffdc SHA512 45f023bfdaf2294dc47704371dda2531aedde49977e7a9b810998a3be972fae70c44fb0ad6285e247fb6a428e00c056ab1698443d339edebdc84a37f091e528d WHIRLPOOL 70c367bb1b77e0868c3125cd4054616418f68c3ec85805d0f0059a49e3e3f5452342d1f608c6919ba052ad1ffe1505aef2775590e9ced887a95aeeb80e5bed7a
DIST clfft-2.10.2.tar.gz 988720 SHA256 7be3a706a533e1a54f9b78e13f91d19603ce082fb32c25b48d1216f5424515d7 SHA512 4f192ddf2f578aeadc350534b28036618b15a77bd216231283597515de5cef558d8e1aead1345d8f03f76dba17e41bc001af7845f502d16effa18c093f3acffe WHIRLPOOL 94cb59852b879df74e98fb7a12bdcacac9edfdd393a5aaab405b3dfa72f5c3775169135ad84d0ca627a095fcdfb73f71c8900b0d1bc707b0ee0433a9260d5025
+DIST clfft-2.12.0.tar.gz 1008780 SHA256 c623a1b00cd8fe31583044dd98f8d0d0d2b3bda41628098ddb3edc8530099600 SHA512 8ee21847f2877989a1b6a62f62807e2cfd6d6845ed36702de775eb9dbccfed898e9969cce7bb93827745b5d65a5d91aaf07c565c92e65b6fefe3028efa9c23c9 WHIRLPOOL d582cb0d1946574eee187d3231ab5078980177af3b6752644e52d85999723dc21b31919916d6506050d9abadc104bec2978ae4759b70c2c3a0ffdd1fefb6396b
diff --git a/sci-libs/clfft/clfft-2.12.0.ebuild b/sci-libs/clfft/clfft-2.12.0.ebuild
new file mode 100644
index 000000000..1776ddd5f
--- /dev/null
+++ b/sci-libs/clfft/clfft-2.12.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+MY_PN="clFFT"
+
+DESCRIPTION="Library containing FFT functions written in OpenCL"
+HOMEPAGE="https://github.com/clMathLibraries/clFFT"
+SRC_URI="https://github.com/clMathLibraries/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="callback_client +client examples test"
+
+RDEPEND="
+ >=sys-devel/gcc-4.6:*
+ virtual/opencl
+ dev-libs/boost"
+DEPEND="${RDEPEND}"
+# test? (
+# dev-cpp/gtest
+# sci-libs/fftw:3.0
+# )"
+
+# The tests only get compiled to an executable named Test, which is not recogniozed by cmake.
+# Therefore src_test() won't execute any test.
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_PN}-${PV}/src"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if [[ $(gcc-major-version) -lt 4 ]] || ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) ; then
+ die "Compilation with gcc older than 4.6 is not supported."
+ fi
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build callback_client CALLBACK_CLIENT)
+ $(cmake-utils_use_build client CLIENT)
+ $(cmake-utils_use_build examples EXAMPLES)
+ $(cmake-utils_use_build test TEST)
+ -DBoost_USE_STATIC_LIBS=OFF
+ )
+ cmake-utils_src_configure
+}