aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-chemistry/curvefit/ChangeLog22
-rw-r--r--sci-chemistry/curvefit/Manifest1
-rw-r--r--sci-chemistry/curvefit/curvefit-1.40.ebuild54
-rw-r--r--sci-chemistry/curvefit/metadata.xml5
-rw-r--r--sci-libs/iml/ChangeLog12
-rw-r--r--sci-libs/iml/Manifest2
-rw-r--r--sci-libs/iml/files/iml-1.0.3-cblas.patch41
-rw-r--r--sci-libs/iml/files/iml-1.0.3-fix-undefined-symbol.patch (renamed from sci-libs/iml/files/fix-undefined-symbol.patch)6
-rw-r--r--sci-libs/iml/files/iml-1.0.3-repl_removal.patch27
-rw-r--r--sci-libs/iml/files/iml-1.0.3-use-any-cblas-implementation.patch14
-rw-r--r--sci-libs/iml/iml-1.0.3-r2.ebuild37
-rw-r--r--sci-libs/iml/iml-1.0.3.ebuild43
-rw-r--r--sci-physics/LoopTools/ChangeLog7
-rw-r--r--sci-physics/LoopTools/LoopTools-2.8.ebuild (renamed from sci-physics/LoopTools/LoopTools-2.7-r1.ebuild)0
-rw-r--r--sci-physics/LoopTools/Manifest2
-rw-r--r--sci-physics/LoopTools/files/LoopTools-2.8-makefile.patch (renamed from sci-physics/LoopTools/files/LoopTools-2.7-makefile.patch)0
-rw-r--r--sci-physics/thepeg/ChangeLog10
-rw-r--r--sci-physics/thepeg/Manifest5
-rw-r--r--sci-physics/thepeg/files/thepeg-1.8.0-java.patch37
-rw-r--r--sci-physics/thepeg/metadata.xml20
-rw-r--r--sci-physics/thepeg/thepeg-1.8.0.ebuild92
-rw-r--r--sci-visualization/paraview/ChangeLog6
-rw-r--r--sci-visualization/paraview/paraview-3.14.1-r3.ebuild (renamed from sci-visualization/paraview/paraview-3.14.1-r2.ebuild)5
23 files changed, 357 insertions, 91 deletions
diff --git a/sci-chemistry/curvefit/ChangeLog b/sci-chemistry/curvefit/ChangeLog
new file mode 100644
index 000000000..8f46e69a4
--- /dev/null
+++ b/sci-chemistry/curvefit/ChangeLog
@@ -0,0 +1,22 @@
+# ChangeLog for sci-chemistry/curvefit
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 14 Sep 2012; Justin Lecher <jlec@gentoo.org> curvefit-1.40.ebuild:
+ Quote sed correctly
+
+ 14 Sep 2012; Justin Lecher <jlec@gentoo.org> curvefit-1.40.ebuild:
+ And it sits in EPREFIX
+
+ 14 Sep 2012; Justin Lecher <jlec@gentoo.org> curvefit-1.40.ebuild:
+ We have ls in usr/bin
+
+ 14 Sep 2012; Justin Lecher <jlec@gentoo.org> curvefit-1.40.ebuild:
+ Also include gcc-4.1 libdir in rpath
+
+*curvefit-1.40 (14 Sep 2012)
+
+ 14 Sep 2012; Justin Lecher <jlec@gentoo.org> +curvefit-1.40.ebuild,
+ +metadata.xml:
+ New addition
+
diff --git a/sci-chemistry/curvefit/Manifest b/sci-chemistry/curvefit/Manifest
new file mode 100644
index 000000000..e3af02270
--- /dev/null
+++ b/sci-chemistry/curvefit/Manifest
@@ -0,0 +1 @@
+DIST curvefit.linux.tar.gz 72480 SHA256 f0b1f8cc7e81e106b044719e42e653d6488c17ceb2048b14468a1a09a8bcc790 SHA512 657c4a08d2278cfbcfbe890ba7488187c9962d01ede4d79758f5e46559889152a2fad354226c000628025757a2d11cf1d8f2622dcead60683136ac2e45e93898 WHIRLPOOL fb1e512f65056c6937564e26151f20367e4c250e45197c9b19fb425ec7d1197bcd2a7a0629247d57b5ccf5de2aa60c531bfc2666e2d8d33ec5599567db09bff5
diff --git a/sci-chemistry/curvefit/curvefit-1.40.ebuild b/sci-chemistry/curvefit/curvefit-1.40.ebuild
new file mode 100644
index 000000000..5429531ac
--- /dev/null
+++ b/sci-chemistry/curvefit/curvefit-1.40.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit multilib
+
+DESCRIPTION="Linear and non-linear least squares fitting"
+HOMEPAGE="http://cpmcnet.columbia.edu/dept/gsas/biochem/labs/palmer/software/curvefit.html"
+SRC_URI="http://cpmcnet.columbia.edu/dept/gsas/biochem/labs/palmer/software/curvefit.linux.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ sci-libs/blas-reference
+ sys-devel/gcc:4.1"
+DEPEND="dev-util/patchelf"
+
+S="${WORKDIR}"/linux
+
+QA_PREBUILT="opt/bin/.*"
+
+src_install() {
+ local _exe
+ sed \
+ -e 's: xmgr : xmgrace :g' \
+ -e "s: /bin/ls:${EPREFIX}/bin/ls:g" \
+ -i batch_curve curveplot || die
+
+ exeinto /opt/bin
+ if use x86; then
+ _exe=./linux_32/curvefit
+ elif use amd64; then
+ _exe=./linux_64/curvefit
+ fi
+
+ patchelf --set-rpath "${EPREFIX}/opt/${PN}:${EPREFIX}/usr/$(get_libdir)/gcc/x86_64-pc-linux-gnu/4.1.2/" ${_exe}
+
+ doexe batch_curve curveplot ${_exe}
+
+ dosym ../../usr/$(get_libdir)/libblas.so /opt/${PN}/libblas.so.3
+
+ dodoc Versions
+ dohtml curvefit_manual.html
+
+ if use examples; then
+ insinto /usr/share/${PN}/examples/
+ doins sample*
+ fi
+}
diff --git a/sci-chemistry/curvefit/metadata.xml b/sci-chemistry/curvefit/metadata.xml
new file mode 100644
index 000000000..d369d068f
--- /dev/null
+++ b/sci-chemistry/curvefit/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+</pkgmetadata>
diff --git a/sci-libs/iml/ChangeLog b/sci-libs/iml/ChangeLog
index 7310d1e95..8bee9988f 100644
--- a/sci-libs/iml/ChangeLog
+++ b/sci-libs/iml/ChangeLog
@@ -1,7 +1,17 @@
# ChangeLog for sci-libs/iml
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*iml-1.0.3-r2 (13 Sep 2012)
+
+ 13 Sep 2012; François Bissey <francois.bissey@canterbury.ac.nz>
+ -iml-1.0.3.ebuild, +iml-1.0.3-r2.ebuild, -files/iml-1.0.3-cblas.patch,
+ +files/iml-1.0.3-fix-undefined-symbol.patch,
+ +files/iml-1.0.3-repl_removal.patch,
+ +files/iml-1.0.3-use-any-cblas-implementation.patch,
+ -files/fix-undefined-symbol.patch:
+ bring to s-o-g level
+
*iml-1.0.3 (23 Nov 2009)
23 Nov 2009; François Bissey <f.r.bissey@massey.ac.nz> +iml-1.0.3.ebuild,
diff --git a/sci-libs/iml/Manifest b/sci-libs/iml/Manifest
index 4cedfb6be..2f658aa1e 100644
--- a/sci-libs/iml/Manifest
+++ b/sci-libs/iml/Manifest
@@ -1 +1 @@
-DIST iml-1.0.3.tar.gz 395160 RMD160 6b845c476158ab977226a69fd8baa3e95bf8d3a8 SHA1 3783e6e0c5aacd0113f30eb731d12de981de6a5e SHA256 fc626debbf8f84689398f4b941a6c1ded0910eea4388e169bf63c48e257b0395
+DIST iml-1.0.3.tar.gz 395160 SHA256 fc626debbf8f84689398f4b941a6c1ded0910eea4388e169bf63c48e257b0395 SHA512 92e76a7c08ca6e425153d8c614783064a80077ad9859e1c1460595b5e29e614c6eaf8b330a5f3c1b564209ca8265f93d8485cd5cb376e96f01dc81bf9751a67a WHIRLPOOL c0b65d570513ee74d1659863005f2922f9e91e423ef5c701b665912a3d1fa9c5c389a9d97a0eabbed3334ac0111e815b37a69748a50326a6100903c5ac521722
diff --git a/sci-libs/iml/files/iml-1.0.3-cblas.patch b/sci-libs/iml/files/iml-1.0.3-cblas.patch
deleted file mode 100644
index c9a6a1faa..000000000
--- a/sci-libs/iml/files/iml-1.0.3-cblas.patch
+++ /dev/null
@@ -1,41 +0,0 @@
---- configure.ac.orig 2009-11-23 09:30:12.000000000 +1300
-+++ configure.ac 2009-11-23 11:35:59.000000000 +1300
-@@ -3,6 +3,7 @@
- AC_PREREQ(2.59)
- AC_INIT(IML, 1.0.3)
- AC_CONFIG_AUX_DIR(config)
-+AC_CONFIG_MACRO_DIR(config)
- AM_CONFIG_HEADER(config.h:config-h.in)
- AC_CONFIG_SRCDIR([src/RNSop.c])
- AM_INIT_AUTOMAKE
-@@ -55,11 +56,18 @@
- respectively when running configure.
- )])
-
--IML_CHECK_ATLAS(,,[AC_MSG_ERROR(
--ATLAS not found!
--ATLAS version 3.0 or greater is required for this library to compile. Please make sure ATLAS is installed and specify the header and libraries location with the options --with-atlas-include=<path> and --with-atlas-lib=<path> respectively when running configure.
--)])
-+AC_CHECK_HEADERS([cblas.h],
-+ [cblas_headers_found=yes; break;])
-+
-+AS_IF([test "x$cblas_headers_found" != "xyes"],
-+ [AC_MSG_ERROR([Unable to find the cblas headers check your installation])])
-+
-+AC_ARG_WITH(cblas-lib,
-+ AC_HELP_STRING([--with-cblas-lib=<lib>],[Specify the flags for cblas.]),
-+ with_cblas_lib=$withval)
-+ATLAS_LIBS="$with_cblas_lib"
-
-+AC_SUBST(ATLAS_LIBS)
- AC_SUBST(LDFLAGS)
- AC_SUBST(ac_aux_dir)
-
---- Makefile.am~ 2009-11-23 11:38:44.000000000 +1300
-+++ Makefile.am 2009-11-23 11:38:44.000000000 +1300
-@@ -1,3 +1,5 @@
-+ACLOCAL_AMFLAGS = -I config
-+
- EXTRA_DIST = bootstrap
-
- SUBDIRS = repl config src doc tests examples
diff --git a/sci-libs/iml/files/fix-undefined-symbol.patch b/sci-libs/iml/files/iml-1.0.3-fix-undefined-symbol.patch
index 1521d1536..53b14250b 100644
--- a/sci-libs/iml/files/fix-undefined-symbol.patch
+++ b/sci-libs/iml/files/iml-1.0.3-fix-undefined-symbol.patch
@@ -1,11 +1,11 @@
---- nullspace.c.orig 2008-08-12 15:17:18.000000000 +0200
-+++ nullspace.c 2008-08-12 15:12:15.000000000 +0200
+--- src/nullspace.c.orig 2009-11-23 15:01:49.200283384 +0000
++++ src/nullspace.c 2009-11-23 15:03:00.862295995 +0000
@@ -253,7 +253,7 @@
for (i = 0; i < m; i++) {
for (j = 0; j < m; j++)
mpz_init_set_ui(mp_N[i * m + j], 0);
- mpz_init_ui(mp_N[i * m + i], 1);
-+ mpz_init_set_ui(mp_N[i * m + i], 1);
++ mpz_set_ui(mp_N[i * m + i], 1);
}
*mp_N_pass = mp_N;
} else { /* r>0 and s>0 */
diff --git a/sci-libs/iml/files/iml-1.0.3-repl_removal.patch b/sci-libs/iml/files/iml-1.0.3-repl_removal.patch
new file mode 100644
index 000000000..0be719b87
--- /dev/null
+++ b/sci-libs/iml/files/iml-1.0.3-repl_removal.patch
@@ -0,0 +1,27 @@
+--- configure.ac.orig 2011-01-13 22:39:44.640530988 +1300
++++ configure.ac 2011-01-13 22:40:15.462530988 +1300
+@@ -63,7 +63,6 @@
+ AC_OUTPUT([
+ Makefile
+ config/Makefile
+- repl/Makefile
+ src/Makefile
+ doc/Makefile
+ examples/Makefile
+--- Makefile.am.orig 2011-01-13 22:40:32.171530988 +1300
++++ Makefile.am 2011-01-13 22:41:39.874530988 +1300
+@@ -1,3 +1,3 @@
+ EXTRA_DIST = bootstrap
+
+-SUBDIRS = repl config src doc tests examples
++SUBDIRS = config src doc tests examples
+--- src/Makefile.am.orig 2011-01-13 22:41:53.012530988 +1300
++++ src/Makefile.am 2011-01-13 22:42:12.585530988 +1300
+@@ -30,6 +30,5 @@
+ nullspace.c
+
+ libiml_la_CFLAGS = $(AM_CFLAGS)
+-libiml_la_LIBADD = $(EXTERNLIB) \
+- $(top_builddir)/repl/librepl.la
++libiml_la_LIBADD = $(EXTERNLIB)
+ libiml_la_LDFLAGS = -version-info 1:0:1
diff --git a/sci-libs/iml/files/iml-1.0.3-use-any-cblas-implementation.patch b/sci-libs/iml/files/iml-1.0.3-use-any-cblas-implementation.patch
new file mode 100644
index 000000000..c1dd09c88
--- /dev/null
+++ b/sci-libs/iml/files/iml-1.0.3-use-any-cblas-implementation.patch
@@ -0,0 +1,14 @@
+--- configure.ac.orig 2008-06-15 23:51:30.000000000 +0000
++++ configure.ac 2010-08-07 08:38:44.689081000 +0000
+@@ -55,10 +55,7 @@
+ respectively when running configure.
+ )])
+
+-IML_CHECK_ATLAS(,,[AC_MSG_ERROR(
+-ATLAS not found!
+-ATLAS version 3.0 or greater is required for this library to compile. Please make sure ATLAS is installed and specify the header and libraries location with the options --with-atlas-include=<path> and --with-atlas-lib=<path> respectively when running configure.
+-)])
++PKG_CHECK_MODULES([ATLAS], [cblas])
+
+ AC_SUBST(LDFLAGS)
+ AC_SUBST(ac_aux_dir)
diff --git a/sci-libs/iml/iml-1.0.3-r2.ebuild b/sci-libs/iml/iml-1.0.3-r2.ebuild
new file mode 100644
index 000000000..df8342c04
--- /dev/null
+++ b/sci-libs/iml/iml-1.0.3-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+inherit autotools-utils
+
+DESCRIPTION="Integer Matrix Library"
+HOMEPAGE="http://www.cs.uwaterloo.ca/~astorjoh/iml.html"
+SRC_URI="http://www.cs.uwaterloo.ca/~astorjoh/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RESTRICT="mirror"
+
+DEPEND="virtual/cblas"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_AUTORECONF=yes
+AT_M4DIR="config"
+DOCS=( AUTHORS ChangeLog README )
+PATCHES=(
+ "${FILESDIR}"/${P}-use-any-cblas-implementation.patch
+ "${FILESDIR}"/${P}-fix-undefined-symbol.patch
+ "${FILESDIR}"/${P}-repl_removal.patch
+)
+
+src_configure() {
+ myeconfargs=(
+ --with-default="${EPREFIX}"/usr
+ )
+ autotools-utils_src_configure
+}
diff --git a/sci-libs/iml/iml-1.0.3.ebuild b/sci-libs/iml/iml-1.0.3.ebuild
deleted file mode 100644
index 92eab3436..000000000
--- a/sci-libs/iml/iml-1.0.3.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=2
-
-inherit autotools eutils
-
-DESCRIPTION="Integer Matrix Library"
-HOMEPAGE="http://www.cs.uwaterloo.ca/~astorjoh/iml.html"
-SRC_URI="http://www.cs.uwaterloo.ca/~astorjoh/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="mirror"
-IUSE=""
-
-DEPEND="dev-util/pkgconfig
- dev-libs/gmp
- virtual/cblas"
-RDEPEND="dev-libs/gmp
- virtual/cblas"
-
-src_prepare() {
- # do not need atlas specifically any cblas will do...
- epatch "${FILESDIR}/${P}-cblas.patch"
- # apply patch supplied by debian bugreport #494819
- epatch "${FILESDIR}/fix-undefined-symbol.patch"
- eautoreconf
-}
-
-src_configure() {
- econf \
- --enable-shared \
- --with-cblas-lib="$(pkg-config cblas --libs)" \
- || die "econf failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc ChangeLog README
-}
diff --git a/sci-physics/LoopTools/ChangeLog b/sci-physics/LoopTools/ChangeLog
index 8ea8e6b0e..b8c7f9e32 100644
--- a/sci-physics/LoopTools/ChangeLog
+++ b/sci-physics/LoopTools/ChangeLog
@@ -2,6 +2,13 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*LoopTools-2.8 (12 Sep 2012)
+
+ 12 Sep 2012; Jauhien Piatlicki (jauhien) <piatlicki@gmail.com>
+ -LoopTools-2.7-r1.ebuild, -files/LoopTools-2.7-makefile.patch,
+ +LoopTools-2.8.ebuild, +files/LoopTools-2.8-makefile.patch:
+ version bump
+
*LoopTools-2.7-r1 (28 Aug 2012)
28 Aug 2012; Jauhien Piatlicki (jauhien) <piatlicki@gmail.com>
diff --git a/sci-physics/LoopTools/LoopTools-2.7-r1.ebuild b/sci-physics/LoopTools/LoopTools-2.8.ebuild
index 76182c1fb..76182c1fb 100644
--- a/sci-physics/LoopTools/LoopTools-2.7-r1.ebuild
+++ b/sci-physics/LoopTools/LoopTools-2.8.ebuild
diff --git a/sci-physics/LoopTools/Manifest b/sci-physics/LoopTools/Manifest
index 2ebf749af..9da4f8349 100644
--- a/sci-physics/LoopTools/Manifest
+++ b/sci-physics/LoopTools/Manifest
@@ -1 +1 @@
-DIST LoopTools-2.7.tar.gz 523999 SHA256 23d7a92232e3757394c3e10d50c3966d06afa68d87b157b2a521c97f12daac9e SHA512 6bee45ca0aac88c81b42bb622cd0cf00c0c9498d5952a7d568703e165a27981f7d93415e48b891d8cd4126db9f18f832248f0b63d6d74e5100b694697d56fb78 WHIRLPOOL b347b2c3518935515208bddf07b81497788defc30fa1c80fa3a8ceb550e39363e69bb91fd3954e768db7ea908f21249802297f9dc207c60aab5f5c4e6f6db21c
+DIST LoopTools-2.8.tar.gz 545221 SHA256 364bea8ac9aa5a9ad2aea7686a885d09fbe1c1a6ded9ba33b6781e063fa9ee4e SHA512 e50ec398229e2d8c0d7d4d0ef6bf523798145714ad6acbb9e018a40301e3ccc968d833eb20de4e4fb44e372de5f1abb9a9ebfc6e63d05339470cfb9143c72aa4 WHIRLPOOL 55cdf6f4aba6347b851576b9efd5e879d0fd4df70ef6c46d4c3d4b6b1ce20cb572c4d32f4afde792a8d411f862b871bc8fe1948dcdf3931ffd47b6bd15cd0116
diff --git a/sci-physics/LoopTools/files/LoopTools-2.7-makefile.patch b/sci-physics/LoopTools/files/LoopTools-2.8-makefile.patch
index 10df86d5a..10df86d5a 100644
--- a/sci-physics/LoopTools/files/LoopTools-2.7-makefile.patch
+++ b/sci-physics/LoopTools/files/LoopTools-2.8-makefile.patch
diff --git a/sci-physics/thepeg/ChangeLog b/sci-physics/thepeg/ChangeLog
new file mode 100644
index 000000000..35a5eb321
--- /dev/null
+++ b/sci-physics/thepeg/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-physics/thepeg
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*thepeg-1.8.0 (07 Sep 2012)
+
+ 07 Sep 2012; Jauhien Piatlicki (jauhien) <piatlicki@gmail.com>
+ +thepeg-1.8.0.ebuild, +files/thepeg-1.8.0-java.patch, +metadata.xml:
+ New Ebuild for bug #424003 thanks to hasufell, mgorny and xarthisius.
+
diff --git a/sci-physics/thepeg/Manifest b/sci-physics/thepeg/Manifest
new file mode 100644
index 000000000..5f93a1391
--- /dev/null
+++ b/sci-physics/thepeg/Manifest
@@ -0,0 +1,5 @@
+DIST GRV98nlo.LHgrid 221906 SHA256 dca2cd4f13c6e9750da3cb1a1260c1db2e6b9ede9988f92f85e20524df0fe1d0 SHA512 ff615ab723d1f5ed8bd0187031fae441d41d6152938fd7d72d11fcfa7ffbee40704d2341e6d922432ae1f9fb5563210a9010d9466dda5c4f80c301bc4b563cd1 WHIRLPOOL be92c2c0fe0152dfff6c7aea9a937af42b553bde5fbe387774520805a0fa8601698e4545cb8dea70f7ccfb96306f8086545bca600f9bf02417dcf17518b5451a
+DIST MRST2001nlo.LHgrid 719690 SHA256 2f925ac31f458b81cfeb2291961ec5ef8dba30f543b0e758c1fb2bd41bde6139 SHA512 d477bcc678a17ed6ba8e13c5b9b009c2f1c7632793ca69320cf6e132ecac315521b9cdc2da9bd7cadc94f4e6218d2d41f9ae2e77c1c9a3a5d13770ef9fe7124d WHIRLPOOL 711f0e353d2b68e5c6ed4a42756b17b63289b5b9890cd3b07fa9766748556e8bd2aedbd33b59840347e351176f098bd710d590849e76b237709655bb6bf8d370
+DIST ThePEG-1.8.0.tar.bz2 1085822 SHA256 4b22fda1078f410b999a23a17f611c9ae3a7f0f4cee4e83dc82c9336b7adf037 SHA512 34a0aae5450b8d8668fbcd786ddb3add63f827d075206abab876db2f3a4a22e0c8cb7bbe3a826180bab2f36db2ffec54e8dafdefe41bcb47d4b16b1f4f8c298a WHIRLPOOL 907c93f157759988ea30c23554505b98a0891c246e62a227dfb23eca2d5e16fa3e83dbc0486ca634d35eba9a48e5a500a6ca78df69a6120d7ce860ba9bc01cb2
+DIST cteq5l.LHgrid 134797 SHA256 83c92bc90fd6e12be9cd76bc032eca26dcedbe90f0c11aef843bbf54734d5bba SHA512 1ba41fd773104a933af6f37745dcb6f8422e1aece74ba2b1e15a5fb69fdaf694336c0ec1dc6fbc964d2cf3fe363d17ca0c01a6c2ba6def0afa4389cb4083f34b WHIRLPOOL 8a86877fcbae2b45576e3fae08dfd4771c668257893ba2f813c578641dce9800f42bfd57d0d8ac2abc6bf7cd40921020478f1912014a36cfb722ed408ca1430f
+DIST cteq6ll.LHpdf 1461 SHA256 a3c6bd1ebea30f75fa23fa94922ba281872a66e59465b61f73a0f3629c2b5c03 SHA512 b89a87d1c1c7cc910aa4af53abc3cc6550670a5a6332989232d33c7da1ba01ce49bbbf9f3bb454e673312fb5bc1679f86eea18f95a1443d1c80d3a622e2b8728 WHIRLPOOL 3eeba4277668b92bfa0de3d0fb27d0d9b940904061b6aa212936e4a9b86f9955188b81d9572672f64155abc7f2c6184fc90f8f81dd7eabbe1b015b749a5af304
diff --git a/sci-physics/thepeg/files/thepeg-1.8.0-java.patch b/sci-physics/thepeg/files/thepeg-1.8.0-java.patch
new file mode 100644
index 000000000..45b0e9559
--- /dev/null
+++ b/sci-physics/thepeg/files/thepeg-1.8.0-java.patch
@@ -0,0 +1,37 @@
+--- java/Makefile.am
++++ java/Makefile.am
+@@ -11,8 +12,7 @@
+
+ CLEANFILES = ThePEG.jar thepeg.sh
+
+-jardir = $(pkglibdir)
+-nodist_jar_DATA = ThePEG.jar
++noinst_DATA = ThePEG.jar
+
+ dist_noinst_DATA = $(JAVASOURCES) jar-manifest
+
+@@ -34,7 +34,7 @@
+ $(JAR) cmf ThePEG/jar-manifest ThePEG.jar ThePEG/*.class
+
+ thepeg.sh: thepeg.install Makefile
+- sed -e s:@pkglibdir[@]:$(pkglibdir):g \
++ sed -e s:@datadir[@]:$(datadir):g \
+ -e s:@bindir[@]:$(bindir):g \
+ -e s:@java[@]:$(JAVA):g $(srcdir)/thepeg.install > thepeg.sh
+ chmod +x thepeg.sh
+--- java/thepeg.install
++++ java/thepeg.install
+@@ -1,6 +1,6 @@
+ #!/bin/sh
+
+-pkglibdir=@pkglibdir@
++source @datadir@/thepeg/package.env
+ bindir=@bindir@
+
+ ThePEG_CMD="${bindir}/setupThePEG"
+@@ -19,4 +19,4 @@
+
+
+
+-exec @java@ ${HEADLESS} -jar ${pkglibdir}/ThePEG.jar ${ThePEG_CMD} "$@"
++exec @java@ ${HEADLESS} -jar ${CLASSPATH} ${ThePEG_CMD} "$@"
diff --git a/sci-physics/thepeg/metadata.xml b/sci-physics/thepeg/metadata.xml
new file mode 100644
index 000000000..1bffb2a93
--- /dev/null
+++ b/sci-physics/thepeg/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>piatlicki@gmail.com</email>
+</maintainer>
+<longdescription>
+ Toolkit for High Energy Physics Event Generation.
+ ThePEG has been broken out from the PYTHIA7 program
+ to better factorize the parts which were PYTHIA-specific
+ from those which are general model-independent components
+ of the toolkit and which can be used by any event generator model.
+</longdescription>
+<use>
+ <flag name='hepmc'>Adds support for High Energy Physics Monte Carlo
+ Generators <pkg>sci-physics/hepmc</pkg></flag>
+ <flag name='lhapdf'>Adds support for <pkg>sci-physics/lhapdf</pkg></flag>
+</use>
+</pkgmetadata>
diff --git a/sci-physics/thepeg/thepeg-1.8.0.ebuild b/sci-physics/thepeg/thepeg-1.8.0.ebuild
new file mode 100644
index 000000000..abddbcd4f
--- /dev/null
+++ b/sci-physics/thepeg/thepeg-1.8.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit autotools elisp-common eutils java-pkg-opt-2
+
+MYP=ThePEG-${PV}
+
+DESCRIPTION="Toolkit for High Energy Physics Event Generation"
+HOMEPAGE="http://home.thep.lu.se/ThePEG/"
+SRC_URI="http://www.hepforge.org/archive/thepeg/${MYP}.tar.bz2
+ test? ( hepmc? (
+ http://www.hepforge.org/archive/lhapdf/pdfsets/current/cteq6ll.LHpdf
+ http://www.hepforge.org/archive/lhapdf/pdfsets/current/cteq5l.LHgrid
+ http://www.hepforge.org/archive/lhapdf/pdfsets/current/GRV98nlo.LHgrid
+ http://www.hepforge.org/archive/lhapdf/pdfsets/current/MRST2001nlo.LHgrid ) )"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="emacs hepmc java lhapdf test zlib"
+
+RDEPEND="sci-libs/gsl
+ dev-lang/perl
+ emacs? ( virtual/emacs )
+ hepmc? ( sci-physics/hepmc )
+ java? ( >=virtual/jre-1.5 )
+ lhapdf? ( sci-physics/lhapdf )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}
+ test? ( sys-process/time )"
+
+S="${WORKDIR}/${MYP}"
+
+pkg_setup() {
+ elog "There is an extra option on package Rivet not yet in Gentoo:"
+ elog "You can use the env variable EXTRA_ECONF variable for this:"
+ elog "EXTRA_ECONF=\"--with-rivet=DIR\""
+ elog "where DIR - location of Rivet installation"
+ java-pkg-opt-2_pkg_setup
+}
+
+src_prepare() {
+ find -name 'Makefile.am' -exec sed -i '1ipkgdatadir=$(datadir)/thepeg' {} \; \
+ || die "changing pkgdatadir name failed"
+ sed -i '/dist_pkgdata_DATA = ThePEG.el/d' lib/Makefile.am \
+ || die "preventing install ThePEG.el in pkgdatadir failed"
+ epatch "${FILESDIR}"/${P}-java.patch
+ eautoreconf
+
+ java-pkg-opt-2_src_prepare
+}
+
+src_configure() {
+ econf \
+ --disable-silent-rules \
+ $(use_with hepmc hepmc "${EPREFIX}"/usr) \
+ $(use_with java javagui) \
+ $(use_with lhapdf LHAPDF "${EPREFIX}"/usr) \
+ $(use_with zlib zlib "${EPREFIX}"/usr)
+}
+
+src_compile() {
+ emake
+ if use emacs; then
+ elisp-compile lib/ThePEG.el || die
+ fi
+}
+
+src_test() {
+ emake LHAPATH="${DISTDIR}" check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ if use emacs; then
+ elisp-install ${PN} lib/ThePEG.el lib/ThePEG.elc || die
+ fi
+ use java && java-pkg_newjar java/ThePEG.jar
+}
+
+pkg_postinst() {
+ if use emacs; then
+ elog "To use installed elisp file you should add"
+ elog "(add-to-list 'load-path \"${SITELISP}/${PN}\")"
+ elog "(load \"ThePEG\")"
+ elog "to your .emacs file"
+ fi
+}
diff --git a/sci-visualization/paraview/ChangeLog b/sci-visualization/paraview/ChangeLog
index 67889a1d4..703030192 100644
--- a/sci-visualization/paraview/ChangeLog
+++ b/sci-visualization/paraview/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*paraview-3.14.1-r3 (16 Sep 2012)
+
+ 16 Sep 2012; François Bissey <francois.bissey@canterbury.ac.nz>
+ -paraview-3.14.1-r2.ebuild, +paraview-3.14.1-r3.ebuild:
+ add a ps useflags for gl2ps
+
*paraview-3.14.1-r2 (31 Aug 2012)
31 Aug 2012; François Bissey <francois.bissey@canterbury.ac.nz>
diff --git a/sci-visualization/paraview/paraview-3.14.1-r2.ebuild b/sci-visualization/paraview/paraview-3.14.1-r3.ebuild
index 30bbe3333..5eb288da8 100644
--- a/sci-visualization/paraview/paraview-3.14.1-r2.ebuild
+++ b/sci-visualization/paraview/paraview-3.14.1-r3.ebuild
@@ -20,7 +20,7 @@ RESTRICT="mirror"
LICENSE="paraview GPL-2"
KEYWORDS="~x86 ~amd64"
SLOT="0"
-IUSE="boost cg -coprocessing doc examples +gui mpi mysql nvcontrol +plugins +python webkit ffmpeg theora"
+IUSE="boost cg -coprocessing doc examples +gui mpi mysql postscript nvcontrol +plugins +python webkit ffmpeg theora"
RDEPEND="
~sci-libs/netcdf-4.1.3[cxx,hdf5]
@@ -45,6 +45,7 @@ RDEPEND="
)
ffmpeg? ( virtual/ffmpeg )
theora? ( media-libs/libtheora )
+ postscript? ( x11-libs/gl2ps )
dev-libs/libxml2:2
dev-db/sqlite:3
media-libs/libpng
@@ -160,6 +161,8 @@ src_configure() {
$(cmake-utils_use nvcontrol VTK_USE_NVCONTROL)
$(cmake-utils_use mysql XDMF_USE_MYSQL)
$(cmake-utils_use mysql VTK_USE_MYSQL)
+ $(cmake-utils_use postscript VTK_USE_GL2PS)
+ $(cmake-utils_use postscript VTK_USE_SYSTEM_GL2PS)
$(cmake-utils_use coprocessing PARAVIEW_ENABLE_COPROCESSING)
$(cmake-utils_use ffmpeg VTK_USE_FFMPEG_ENCODER)
$(cmake-utils_use theora VTK_USE_THEORA_ENCODER)