aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/boost-compute/boost-compute-0.5.ebuild')
-rw-r--r--dev-libs/boost-compute/boost-compute-0.5.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-libs/boost-compute/boost-compute-0.5.ebuild b/dev-libs/boost-compute/boost-compute-0.5.ebuild
new file mode 100644
index 000000000..151d1854f
--- /dev/null
+++ b/dev-libs/boost-compute/boost-compute-0.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils cmake-utils
+
+DESCRIPTION="A header-only C++ Computing Library for OpenCL"
+HOMEPAGE="https://github.com/boostorg/compute"
+SRC_URI="https://github.com/boostorg/compute/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost
+ virtual/opencl
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/compute-${PV}"
+
+PATCHES=( "${FILESDIR}/${P}"-CMakeLists.patch )