aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/boost-compute/Manifest1
-rw-r--r--dev-libs/boost-compute/boost-compute-0.5.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/boost-compute/Manifest b/dev-libs/boost-compute/Manifest
index d068af6c5..c5f0f45a7 100644
--- a/dev-libs/boost-compute/Manifest
+++ b/dev-libs/boost-compute/Manifest
@@ -1 +1,2 @@
DIST boost-compute-0.4.tar.gz 282477 SHA256 d6986155d01a02b12351d6c9cc6c85498292209c3949b3a4628c0712ec7cf01b SHA512 7a2b4f227b2f0a46ba44aeddc4b562e125949f262ef057c92b9261c9e0fa7a824323b3dbb0bb5129b76fce4be93bbb1fccf5d681d63663731c83c3ab80e5ceed WHIRLPOOL 9a2831030ae644e42b6b25be00647fde7e09d018035706c8142c6b80fcda6c2c9687a98cb4f7f5fd43e1ca5026d596351be6a62fb3f2ccc149fe9c025e63ca16
+DIST boost-compute-0.5.tar.gz 333192 SHA256 0ddace9f15c98e7dac03729b5d4686e9c43147c87b5674447fc9dac643fb26e4 SHA512 1caa067342698ec3a6a8e23aaf194f8ced41ac9d5b5a6d3d195911116af4a8a778667065681a8b0e0004887258d7cae71f3c7187ebc50c390200d66fd8688002 WHIRLPOOL b16742778b4e77006cee09e1df125e4a2f26c1a39b8a92e41c632f9b8c41031ffd5d6b91a24419f318367a296a09d3878e4daf402a225ce1d74080ebe8419259
diff --git a/dev-libs/boost-compute/boost-compute-0.5.ebuild b/dev-libs/boost-compute/boost-compute-0.5.ebuild
new file mode 100644
index 000000000..151d1854f
--- /dev/null
+++ b/dev-libs/boost-compute/boost-compute-0.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils cmake-utils
+
+DESCRIPTION="A header-only C++ Computing Library for OpenCL"
+HOMEPAGE="https://github.com/boostorg/compute"
+SRC_URI="https://github.com/boostorg/compute/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost
+ virtual/opencl
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/compute-${PV}"
+
+PATCHES=( "${FILESDIR}/${P}"-CMakeLists.patch )