aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/gsl-ocaml/gsl-ocaml-1.10.2.ebuild')
-rw-r--r--dev-ml/gsl-ocaml/gsl-ocaml-1.10.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/gsl-ocaml/gsl-ocaml-1.10.2.ebuild b/dev-ml/gsl-ocaml/gsl-ocaml-1.10.2.ebuild
new file mode 100644
index 000000000..991a51c1f
--- /dev/null
+++ b/dev-ml/gsl-ocaml/gsl-ocaml-1.10.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="OCaml bindings for the GSL library"
+HOMEPAGE="http://bitbucket.org/mmottl/gsl-ocaml"
+SRC_URI="${HOMEPAGE}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="examples test"
+
+DEPEND=">=sci-libs/gsl-1.10"
+RDEPEND="${DEPEND}"
+
+DOCS=( "CHANGES.txt" "README.md" "NOTES.md" "TODO.md" )
+
+src_prepare() {
+ oasis_configure_opts="$(use_enable examples)"
+}