aboutsummaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/mlgmpidl/Manifest2
-rw-r--r--dev-ml/mlgmpidl/mlgmpidl-1.1.ebuild14
-rw-r--r--dev-ml/ocamlgraph/Manifest2
-rw-r--r--dev-ml/ocamlgraph/ocamlgraph-1.2.ebuild18
4 files changed, 17 insertions, 19 deletions
diff --git a/dev-ml/mlgmpidl/Manifest b/dev-ml/mlgmpidl/Manifest
index 1f3a46d51..aa9c3903e 100644
--- a/dev-ml/mlgmpidl/Manifest
+++ b/dev-ml/mlgmpidl/Manifest
@@ -1,2 +1,2 @@
DIST mlgmpidl-1.1.tgz 194002 RMD160 752c865e5355b40f9b3c9babf0c9c378cb3b4009 SHA1 ef26eaa215ccedbfc20c00614f702a06d3a70420 SHA256 8990a56f4c1ff701bb922bacf7f23b40539d123216ac5f9fe0f35967735d6fc9
-EBUILD mlgmpidl-1.1.ebuild 1347 RMD160 5eff2fd937a758d0ac8df13473465551a6b35f73 SHA1 a3135dfdb622b46b1fc086ff8d88901219cbd0a3 SHA256 98f8d303dafc13b7ca0aaa41bd284da84e7d6117adf9d7856238e0d962a38c24
+EBUILD mlgmpidl-1.1.ebuild 1306 RMD160 6864dcd9898822cc61b5bb6eb00750fef89ffb2c SHA1 d03222f5ad460e269004fa4bf6491b37fd4afc9a SHA256 eb577a14243d7de1685e17782eadaa34674bcab41860d522c547a1f1a3d0cfe7
diff --git a/dev-ml/mlgmpidl/mlgmpidl-1.1.ebuild b/dev-ml/mlgmpidl/mlgmpidl-1.1.ebuild
index 4bc14d0d1..fefbd9c56 100644
--- a/dev-ml/mlgmpidl/mlgmpidl-1.1.ebuild
+++ b/dev-ml/mlgmpidl/mlgmpidl-1.1.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: Exp $
+# $Header: $
+
+EAPI="2"
inherit eutils toolchain-funcs
-DESCRIPTION="MLGMPIDL is a package offering an interface to the GMP and MPFR libraries for OCaml version 3.07 or higher."
+DESCRIPTION="MLGMPIDL is an OCaml interface to the GMP and MPFR libraries"
HOMEPAGE="http://www.inrialpes.fr/pop-art/people/bjeannet/mlxxxidl-forge/mlgmpidl/"
SRC_URI="http://gforge.inria.fr/frs/download.php/20228/${PN}-${PV}.tgz"
@@ -13,13 +15,13 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="doc +mpfr"
-RDEPEND="dev-libs/gmp
+RDEPEND=">=dev-lang/ocaml-3.09
+ dev-ml/camlidl
+ dev-libs/gmp
mpfr? ( dev-libs/mpfr )
- >=dev-lang/ocaml-3.09
- dev-ml/camlidl"
-DEPEND="${RDEPEND}
doc? ( app-text/texlive
app-text/ghostscript-gpl )"
+RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
diff --git a/dev-ml/ocamlgraph/Manifest b/dev-ml/ocamlgraph/Manifest
index e64401809..97fe01cb1 100644
--- a/dev-ml/ocamlgraph/Manifest
+++ b/dev-ml/ocamlgraph/Manifest
@@ -1,3 +1,3 @@
AUX ocamlgraph-1.2-makefile.patch 3980 RMD160 fda851982c979d4c4d667bdd803bb9a570f8e3f8 SHA1 74eec2569ad39f35fd784fc13fa16f7d37cbe3f8 SHA256 fa5ce23b1561555c07d51a75b7e2850fdb1b6abe41bc902b9d4f8f99a1473e0c
DIST ocamlgraph-1.2.tar.gz 213426 RMD160 c5ef73069a912ba179adbad3c4e0d629cc91cd54 SHA1 087cd2720c1a3df3f6543db4ad8d81983fcddba0 SHA256 0695a91a3f2abc0f47eafdae4af8a6022154727aec00784a12362d3719ff51f2
-EBUILD ocamlgraph-1.2.ebuild 1006 RMD160 65691ad55fe153b56ea2f8f4a0e1290e3d24f31c SHA1 f04c187df1bc7413f604bec076d233ce7cf74674 SHA256 9675075cb999ab2509e69ce44d45295f20c6dd616ee1c205efa2d243ece78da6
+EBUILD ocamlgraph-1.2.ebuild 978 RMD160 a7cee4a4bfc08a9697bec9cb73b747c07a8b5df3 SHA1 cb2cdf8cb2c81ea561e9a75d03656570626c1faf SHA256 1977d3ab257ca158405a7112aba13536ab7674f7c2799fd162db86a0b5115638
diff --git a/dev-ml/ocamlgraph/ocamlgraph-1.2.ebuild b/dev-ml/ocamlgraph/ocamlgraph-1.2.ebuild
index 3c20a8c59..97ae38e1c 100644
--- a/dev-ml/ocamlgraph/ocamlgraph-1.2.ebuild
+++ b/dev-ml/ocamlgraph/ocamlgraph-1.2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: Exp $
-
-inherit eutils autotools
+# $Header: $
EAPI="2"
+inherit eutils autotools
+
DESCRIPTION="A graph library for Objective Caml"
HOMEPAGE="http://ocamlgraph.lri.fr/"
SRC_URI="http://ocamlgraph.lri.fr/download/${P}.tar.gz"
@@ -13,17 +13,13 @@ SRC_URI="http://ocamlgraph.lri.fr/download/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc examples gtk +ocamlopt"
-RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
-
-DEPEND="${RDEPEND}
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
gtk? ( >=dev-ml/lablgtk-2.6 )"
+RDEPEND="${DEPEND}"
-IUSE="doc examples gtk +ocamlopt"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
+src_prepare() {
epatch "${FILESDIR}/${P}-makefile.patch"
eautoreconf
}