aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lazy_ops/lazy_ops-0.2.0.ebuild')
-rw-r--r--dev-python/lazy_ops/lazy_ops-0.2.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/lazy_ops/lazy_ops-0.2.0.ebuild b/dev-python/lazy_ops/lazy_ops-0.2.0.ebuild
new file mode 100644
index 000000000..d624fb2aa
--- /dev/null
+++ b/dev-python/lazy_ops/lazy_ops-0.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Lazy transposing and slicing of h5py and Zarr data"
+HOMEPAGE="https://github.com/catalystneuro/lazy_ops"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+# There are no source archive with tests available:
+# https://github.com/catalystneuro/lazy_ops/issues/29
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/zarr[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest