aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lazy_ops')
-rw-r--r--dev-python/lazy_ops/Manifest1
-rw-r--r--dev-python/lazy_ops/lazy_ops-0.2.0.ebuild26
-rw-r--r--dev-python/lazy_ops/metadata.xml16
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/lazy_ops/Manifest b/dev-python/lazy_ops/Manifest
new file mode 100644
index 000000000..b5b4cce5e
--- /dev/null
+++ b/dev-python/lazy_ops/Manifest
@@ -0,0 +1 @@
+DIST lazy_ops-0.2.0.tar.gz 5284 BLAKE2B ba8747ba9028103fad7e0cab5eb53ebfefca5e886dcd39a499c8c8c6c8c466dcdb85438fc012f32cff7b98e486fe8154ef4e3c08241c3c9c738f0a399a6f91af SHA512 b0c7e49d37553f56f491d7e7aaeee8e6e18d44f6f34f7148ed98a596573dc26523e9cbc7bb6dce04bae99dbe59cecd35759173985fc203d7e59dfa61592e6955
diff --git a/dev-python/lazy_ops/lazy_ops-0.2.0.ebuild b/dev-python/lazy_ops/lazy_ops-0.2.0.ebuild
new file mode 100644
index 000000000..d624fb2aa
--- /dev/null
+++ b/dev-python/lazy_ops/lazy_ops-0.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Lazy transposing and slicing of h5py and Zarr data"
+HOMEPAGE="https://github.com/catalystneuro/lazy_ops"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+# There are no source archive with tests available:
+# https://github.com/catalystneuro/lazy_ops/issues/29
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/zarr[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/lazy_ops/metadata.xml b/dev-python/lazy_ops/metadata.xml
new file mode 100644
index 000000000..d5101128a
--- /dev/null
+++ b/dev-python/lazy_ops/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">catalystneuro/lazy_ops</remote-id>
+ <remote-id type="pypi">lazy_ops</remote-id>
+ </upstream>
+</pkgmetadata>