aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-gantt')
-rw-r--r--dev-python/python-gantt/Manifest1
-rw-r--r--dev-python/python-gantt/metadata.xml5
-rw-r--r--dev-python/python-gantt/python-gantt-0.6.0.ebuild26
-rw-r--r--dev-python/python-gantt/python-gantt-0.6.0_p20200809.ebuild8
4 files changed, 8 insertions, 32 deletions
diff --git a/dev-python/python-gantt/Manifest b/dev-python/python-gantt/Manifest
index fe170a0a7..607c0bbc8 100644
--- a/dev-python/python-gantt/Manifest
+++ b/dev-python/python-gantt/Manifest
@@ -1,2 +1 @@
-DIST python-gantt-0.6.0.tar.gz 53522 BLAKE2B e66b6ae0609372e66e8858c4f3c356d774fea879b5a1bee9f2c62fec4c8f3bc99fa79a5066df469d24448c8b2f0bf9f9493b6099f71db75e3fbc87b351af8a1d SHA512 916595bc572bac3b8c2e593d18d4087446b0de7a08902788c1c5c97496518e75c6c4e82434709bf80753da04f307bde7b543e7f0a4b4d5cdaf66f31da2772f9f
DIST python-gantt-0.6.0_p20200809.tar.gz 32423 BLAKE2B e1e34276707d757e5c8386a75318863550dc7cabc1fa9cee161043ec757633819ac2efbd237b20d8497ce2b037aa72f44396dbcbd4c206f264eef4601985323a SHA512 62811ab5ac8aa26bdfa2ec10b621e1aeae84612e628be6555eb71548694dce4d474cc8d0bd56d5db8a40ffee4ac161c8aa11b7a250f8260df6a8175b3672e50b
diff --git a/dev-python/python-gantt/metadata.xml b/dev-python/python-gantt/metadata.xml
index 3febd988f..18071f943 100644
--- a/dev-python/python-gantt/metadata.xml
+++ b/dev-python/python-gantt/metadata.xml
@@ -1,4 +1,4 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
@@ -13,4 +13,7 @@
Python-Gantt makes it possible to easily draw gantt charts from Python
and export outputs as scalable vector graphics (SVG).
</longdescription>
+ <upstream>
+ <remote-id type="github">stefanSchinkel/gantt</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-python/python-gantt/python-gantt-0.6.0.ebuild b/dev-python/python-gantt/python-gantt-0.6.0.ebuild
deleted file mode 100644
index 2c8347c49..000000000
--- a/dev-python/python-gantt/python-gantt-0.6.0.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6..8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Draw Gantt charts from Python"
-HOMEPAGE="https://pypi.org/project/python-gantt/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/svgwrite[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests nose
-
-python_test() {
- nosetests -v || die "nose tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/python-gantt/python-gantt-0.6.0_p20200809.ebuild b/dev-python/python-gantt/python-gantt-0.6.0_p20200809.ebuild
index 379816b05..b5fdf845b 100644
--- a/dev-python/python-gantt/python-gantt-0.6.0_p20200809.ebuild
+++ b/dev-python/python-gantt/python-gantt-0.6.0_p20200809.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+EAPI=8
+PYTHON_COMPAT=( python3_10 )
inherit distutils-r1
@@ -30,7 +30,7 @@ python_prepare() {
-e "s/matplotlib==3.0.3/matplotlib/g"\
-e "s/numpy==1.16.3/numpy/g"\
setup.py || die
- distutils-r1_python_prepare_all
+ python_prepare_all
}
distutils_enable_tests pytest