aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/traits/traits-6.3.2.ebuild')
-rw-r--r--dev-python/traits/traits-6.3.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/traits/traits-6.3.2.ebuild b/dev-python/traits/traits-6.3.2.ebuild
new file mode 100644
index 000000000..4d3c699a5
--- /dev/null
+++ b/dev-python/traits/traits-6.3.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
+HOMEPAGE="
+ https://docs.enthought.com/traits/
+ https://github.com/enthought/traits
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+# ToDo: Fix doc building:
+# AttributeError: 'NoDefaultSpecified' object has no attribute '__name__'
+#distutils_enable_sphinx docs/source --no-autodoc
+
+python_prepare_all() {
+ sed -i -e "s/'-O3'//g" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ ${EPYTHON} -m unittest discover || die
+}