aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/traits')
-rw-r--r--dev-python/traits/Manifest4
-rw-r--r--dev-python/traits/metadata.xml1
-rw-r--r--dev-python/traits/traits-6.0.0.ebuild43
-rw-r--r--dev-python/traits/traits-6.3.2.ebuild (renamed from dev-python/traits/traits-6.1.1.ebuild)16
-rw-r--r--dev-python/traits/traits-6.4.1.ebuild36
5 files changed, 47 insertions, 53 deletions
diff --git a/dev-python/traits/Manifest b/dev-python/traits/Manifest
index 4c0fe0428..c33b93d1f 100644
--- a/dev-python/traits/Manifest
+++ b/dev-python/traits/Manifest
@@ -1,2 +1,2 @@
-DIST traits-6.0.0.tar.gz 441607 BLAKE2B d8f28e8ccdca8d65a4abb71210f6fe36d6fd2eb07ce5e8f1d374a64cf44e9ce95a318274c68b6791c91f2e105c4f9385e4a743d33434b608ce1d939693958e33 SHA512 b89f844b18c97e2fd2239fc74253e83f255aa231a3d02207a5acf27da7686c32c57cb7c36ffb92a59f7bfa4d98a5e1a95ae2b70e34aa4577a7ae82c8c6756e1e
-DIST traits-6.1.1.tar.gz 567019 BLAKE2B 4b6ed46c87b1fda2a2001299106b5aacafbe8b148ba0564c4f39b67a8de76f6713366c8b00841db254a26c87a7b2b73b6935ecade770d92ad972aa8a0425cecf SHA512 7f7e9f11d4861c02164ae1ce595888859c8ce23213290cfc3ac11df100d33beeeea4c7def6799b70ef2d090b3f7bd98407f3605affff0867914d0fe0164dd50f
+DIST traits-6.3.2.tar.gz 9517139 BLAKE2B 9c6209a24fd07def86699174a66e2e0b3332670d974a75ead9486187c37e1c2c25b2a0c47e5444a03577931411ce6938b3b9ba195261a46c86d660c5abe9b502 SHA512 792004d88d2a00a1e9ba03974d58ec692b620f3c45aaf3bd82f93396818df8663a86903d43806c877230a66c5c8fee4d68268ed9355c166af00b5d060ba14c7d
+DIST traits-6.4.1.tar.gz 9527016 BLAKE2B 12036eeb845cc3014b0cba9984e1c1686a6720630678d440a2059c47916c08284b1f823ca566dcb6c1c86594ebec5400bb2a8c44d43d765a25d00e157fbbda74 SHA512 04b936195d57320c02fee9f0d5e7dbcfee28add422c151bd4aaa6d1c58c59f8de7fe54b4df039bb2023ffc9dae9570bba52210cd015ce462e0f736e9439327e5
diff --git a/dev-python/traits/metadata.xml b/dev-python/traits/metadata.xml
index ec9460dd1..2e84467ab 100644
--- a/dev-python/traits/metadata.xml
+++ b/dev-python/traits/metadata.xml
@@ -21,6 +21,7 @@
* Visualization: With the TraitsUI package, GUIs can be generated automatically from traited objects.
</longdescription>
<upstream>
+ <remote-id type="github">enthought/traits</remote-id>
<remote-id type="pypi">traits</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/traits/traits-6.0.0.ebuild b/dev-python/traits/traits-6.0.0.ebuild
deleted file mode 100644
index 0d1a480b1..000000000
--- a/dev-python/traits/traits-6.0.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
-HOMEPAGE="https://docs.enthought.com/traits/
- https://github.com/enthought/traits
- https://pypi.org/project/traits/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- ${RDEPEND}
- )"
-
-python_prepare_all() {
- sed -i -e "s/'-O3'//g" setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib || die
- ${EPYTHON} -m unittest discover || die
-}
diff --git a/dev-python/traits/traits-6.1.1.ebuild b/dev-python/traits/traits-6.3.2.ebuild
index ac4465fe9..4d3c699a5 100644
--- a/dev-python/traits/traits-6.1.1.ebuild
+++ b/dev-python/traits/traits-6.3.2.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{10..11} )
-inherit distutils-r1 virtualx
+inherit distutils-r1 pypi
DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
-HOMEPAGE="https://docs.enthought.com/traits/
+HOMEPAGE="
+ https://docs.enthought.com/traits/
https://github.com/enthought/traits
- https://pypi.org/project/traits/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+"
LICENSE="BSD"
SLOT="0"
@@ -19,7 +19,7 @@ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
-distutils_enable_tests nose
+distutils_enable_tests unittest
# ToDo: Fix doc building:
# AttributeError: 'NoDefaultSpecified' object has no attribute '__name__'
#distutils_enable_sphinx docs/source --no-autodoc
diff --git a/dev-python/traits/traits-6.4.1.ebuild b/dev-python/traits/traits-6.4.1.ebuild
new file mode 100644
index 000000000..ebd3fb97a
--- /dev/null
+++ b/dev-python/traits/traits-6.4.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
+HOMEPAGE="
+ https://docs.enthought.com/traits/
+ https://github.com/enthought/traits
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+# ToDo: Fix doc building:
+# AttributeError: 'NoDefaultSpecified' object has no attribute '__name__'
+#distutils_enable_sphinx docs/source --no-autodoc
+
+python_prepare_all() {
+ sed -i -e "s/'-O3'//g" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs traits
+}