aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/num2words/Manifest1
-rw-r--r--dev-python/num2words/metadata.xml21
-rw-r--r--dev-python/num2words/num2words-0.5.6.ebuild26
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/num2words/Manifest b/dev-python/num2words/Manifest
new file mode 100644
index 000000000..669f70f9c
--- /dev/null
+++ b/dev-python/num2words/Manifest
@@ -0,0 +1 @@
+DIST num2words-0.5.6.tar.gz 55475 BLAKE2B 954c314762cb63ecf229eee465a7a88688eec00b940a73f6a2fe843a55bee65ce4590a865e607ae665d2248158cb69f196e5e5d9e6d91867305496fe6192de33 SHA512 6f6d979f8352268ee139681b3fecb659e67ba885806801e2424700b6a002883f6326b85497438e721a476b92a145e6f61a61929ec6bd885309f555f86959b66e
diff --git a/dev-python/num2words/metadata.xml b/dev-python/num2words/metadata.xml
new file mode 100644
index 000000000..c98623ef2
--- /dev/null
+++ b/dev-python/num2words/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>horea.christ@gmail.com</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The num2words library converts numbers like 42 to words like forty-two.
+ It supports multiple languages (see the list below for full list of
+ languages) and can even generate ordinal numbers like forty-second
+ (although this last feature is a bit buggy for some languages at the moment).
+ </longdescription>
+ <upstream>
+ <remote-id type="github">savoirefairelinux/num2words</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/num2words/num2words-0.5.6.ebuild b/dev-python/num2words/num2words-0.5.6.ebuild
new file mode 100644
index 000000000..57069dc58
--- /dev/null
+++ b/dev-python/num2words/num2words-0.5.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Modules to convert numbers to words."
+HOMEPAGE="https://github.com/savoirfairelinux/num2words"
+SRC_URI="https://github.com/savoirfairelinux/num2words/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+RDEPEND=""
+
+python_test() {
+ ${EPYTHON} setup.py test || die
+}