aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/plog/plog-1.1.5.ebuild')
-rw-r--r--dev-util/plog/plog-1.1.5.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/plog/plog-1.1.5.ebuild b/dev-util/plog/plog-1.1.5.ebuild
new file mode 100644
index 000000000..9bfddba07
--- /dev/null
+++ b/dev-util/plog/plog-1.1.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Portable, simple and extensible C++ logging library"
+HOMEPAGE="https://github.com/SergiusTheBest/plog"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SergiusTheBest/plog"
+else
+ SRC_URI="https://github.com/SergiusTheBest/plog/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MPL-2.0"
+SLOT="0"
+
+src_install() {
+ doheader -r include/plog
+ dodoc README.md
+}