aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/plog/Manifest1
-rw-r--r--dev-util/plog/plog-1.1.5.ebuild23
-rw-r--r--dev-util/plog/plog-9999.ebuild23
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/plog/Manifest b/dev-util/plog/Manifest
new file mode 100644
index 000000000..c5b00b7ca
--- /dev/null
+++ b/dev-util/plog/Manifest
@@ -0,0 +1 @@
+DIST plog-1.1.5.tar.gz 40453 BLAKE2B 41176a9cb70c796f337ebaa451f511c8d8d70fe95abfb8affa5b67f9f5d7b12355cb8458fc0c441eddcee9eeeeaa47484774140e26efd53408d6b0baaf892f5d SHA512 c16b428e1855c905c486130c8610d043962bedc2b40d1d986c250c8f7fd7139540164a3cbb408ed08298370aa150d5937f358c13ccae2728ce8ea47fa897fd0b
diff --git a/dev-util/plog/plog-1.1.5.ebuild b/dev-util/plog/plog-1.1.5.ebuild
new file mode 100644
index 000000000..9bfddba07
--- /dev/null
+++ b/dev-util/plog/plog-1.1.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Portable, simple and extensible C++ logging library"
+HOMEPAGE="https://github.com/SergiusTheBest/plog"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SergiusTheBest/plog"
+else
+ SRC_URI="https://github.com/SergiusTheBest/plog/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MPL-2.0"
+SLOT="0"
+
+src_install() {
+ doheader -r include/plog
+ dodoc README.md
+}
diff --git a/dev-util/plog/plog-9999.ebuild b/dev-util/plog/plog-9999.ebuild
new file mode 100644
index 000000000..9bfddba07
--- /dev/null
+++ b/dev-util/plog/plog-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Portable, simple and extensible C++ logging library"
+HOMEPAGE="https://github.com/SergiusTheBest/plog"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SergiusTheBest/plog"
+else
+ SRC_URI="https://github.com/SergiusTheBest/plog/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MPL-2.0"
+SLOT="0"
+
+src_install() {
+ doheader -r include/plog
+ dodoc README.md
+}