aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/arachne')
-rw-r--r--sci-biology/arachne/Manifest1
-rw-r--r--sci-biology/arachne/arachne-46233.ebuild41
-rw-r--r--sci-biology/arachne/metadata.xml12
3 files changed, 54 insertions, 0 deletions
diff --git a/sci-biology/arachne/Manifest b/sci-biology/arachne/Manifest
new file mode 100644
index 000000000..c06393105
--- /dev/null
+++ b/sci-biology/arachne/Manifest
@@ -0,0 +1 @@
+DIST arachne-46233.tar.gz 5161566 SHA256 1b2c254a19b4792ec8a6c32ffc3d97c20e43deea3141ee975995221c7ccdf990 SHA512 4ab293e7f4477dd6aeba7c6bc1a78d168cbb811d7f67cbcbc1eea094a7b6bd180bdde6fb1b7c8256ff473dba3d748a43bd426d971575f1c0793289a0b200dc2b WHIRLPOOL 9d18c31fba1e69690d6a20c75b47319298b56c7a73ede0fed55e1d4b30c7783bc7f5d5f54346b1fb05376c54854c4ba7f2f89401bda178c5aac8e39957292ff8
diff --git a/sci-biology/arachne/arachne-46233.ebuild b/sci-biology/arachne/arachne-46233.ebuild
new file mode 100644
index 000000000..71fc0b87e
--- /dev/null
+++ b/sci-biology/arachne/arachne-46233.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Whole genome shotgun assembler for Sanger read lengths (overlap-layout-contig)"
+HOMEPAGE="https://www.broadinstitute.org/crd/wiki
+ http://genome.cshlp.org/content/12/1/177.abstract"
+SRC_URI="ftp://ftp.broadinstitute.org/pub/crd/ARACHNE/latest_source_code/${P}.tar.gz"
+
+LICENSE="MIT" # not exactly MIT ... hence no KEYWORDS
+SLOT="0"
+KEYWORDS=""
+IUSE="doc openmp"
+
+DEPEND="dev-libs/xerces-c
+ doc? ( virtual/latex-base app-text/dvipsk )"
+RDEPEND="${DEPEND}"
+
+# needs >=g++-4.7 but does not compile with 5.3.0
+
+# --disable-openmp to disable requirement for OpenMP-capable compiler
+src_configure() {
+ local myconf=()
+ use openmp || myconf+=( --disable-openmp )
+ econf ${myconf[@]}
+}
+
+# set the following environment variables
+# http://www.broadinstitute.org/crd/wiki/index.php/Setup
+#
+# ARACHNE_PRE
+# ARACHNE_BIN_DIR
+# ARACHNE_PRETTY_HELP
+
+pkg_postinst(){
+ einfo "Please add these to your ~/.bashrc"
+ einfo "limit stacksize 100000"
+ einfo "limit datasize unlimited"
+}
diff --git a/sci-biology/arachne/metadata.xml b/sci-biology/arachne/metadata.xml
new file mode 100644
index 000000000..f68a1b6fa
--- /dev/null
+++ b/sci-biology/arachne/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mmokrejs@fold.natur.cuni.cz</email>
+ <name>Martin Mokrejs</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+</pkgmetadata>