aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/fastqc')
-rw-r--r--sci-biology/fastqc/Manifest2
-rw-r--r--sci-biology/fastqc/fastqc-0.11.3.ebuild48
-rw-r--r--sci-biology/fastqc/fastqc-0.11.9.ebuild40
-rw-r--r--sci-biology/fastqc/files/00fastqc1
-rw-r--r--sci-biology/fastqc/files/build.xml59
-rw-r--r--sci-biology/fastqc/metadata.xml3
6 files changed, 44 insertions, 109 deletions
diff --git a/sci-biology/fastqc/Manifest b/sci-biology/fastqc/Manifest
index 470141cc1..91b60dbc9 100644
--- a/sci-biology/fastqc/Manifest
+++ b/sci-biology/fastqc/Manifest
@@ -1 +1 @@
-DIST fastqc_v0.11.3_source.zip 10073593 BLAKE2B 4b72d8c06c7495baa138a39f4f6140022c9d8a954dd284c3e66fdf547411315425995e72005eb6605559197b094ead9aab28918bf0f89b3a1d49fef00b02ce28 SHA512 bab27d6997ad6525b7804ba9a3a54eec1cdb835d548c2840ae882334902d12eea4bbff549370669176ade76633a5f1d7dc6f7ee865a25f1a41b525764660b471
+DIST fastqc-0.11.9.tar.gz 10077703 BLAKE2B 7922effe383801ae30a4f16cca06d893883af48a730f5640926bc83eedae4df78e956973f1985a5ff9bb83ff061314b80eeecaed738f0eafa7feb59ecfad6984 SHA512 20f46fd9b5608565b6da8ec3bedb1f173a3619b0004bc0987147b1e3240813ef6ebbb07b9bcf2c472272dfad8262ad6edf68055ccad3b81b5ffb63ddc5278a4a
diff --git a/sci-biology/fastqc/fastqc-0.11.3.ebuild b/sci-biology/fastqc/fastqc-0.11.3.ebuild
deleted file mode 100644
index 4be2ae23b..000000000
--- a/sci-biology/fastqc/fastqc-0.11.3.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit java-pkg-2 eutils java-ant-2 prefix
-
-DESCRIPTION="Quality control FASTA/FASTQ sequence files"
-HOMEPAGE="https://www.bioinformatics.babraham.ac.uk/projects/fastqc/"
-SRC_URI="https://www.bioinformatics.babraham.ac.uk/projects/fastqc/fastqc_v"${PV}"_source.zip"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="dev-lang/perl"
-DEPEND="${RDEPEND} >=virtual/jdk-1.5:*"
-BDEPEND="app-arch/unzip"
-
-S="${WORKDIR}"/FastQC
-
-src_prepare(){
- cp "${FILESDIR}"/build.xml . || die
- default
-}
-
-src_compile(){
- ant || die
-}
-
-src_install(){
- insinto "opt/${PN}"
- doins -r bin
- chmod a+x "${ED}/opt/${PN}/bin/fastqc"
- # Add the package's bin directory to the PATH.
- doenvd "${FILESDIR}/00fastqc"
- if use prefix ; then
- hprefixify "${ED}/etc/env.d/00fastqc"
- fi
-
- dodoc README.txt RELEASE_NOTES.txt
-}
-
-pkg_postinst() {
- ewarn "Remember to run: env-update && source \"${EPREFIX}/etc/profile\" if you plan"
- ewarn "to use this tool in a shell before logging out (or restarting"
- ewarn "your login manager)"
-}
diff --git a/sci-biology/fastqc/fastqc-0.11.9.ebuild b/sci-biology/fastqc/fastqc-0.11.9.ebuild
new file mode 100644
index 000000000..be2d3b340
--- /dev/null
+++ b/sci-biology/fastqc/fastqc-0.11.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop java-pkg-2 java-ant-2 xdg
+
+DESCRIPTION="Quality control FASTA/FASTQ sequence files"
+HOMEPAGE="https://www.bioinformatics.babraham.ac.uk/projects/fastqc/"
+SRC_URI="https://github.com/s-andrews/FastQC/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/FastQC-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-lang/perl
+ >=virtual/jre-1.8:*
+"
+DEPEND="
+ dev-lang/perl
+ >=virtual/jdk-1.8:*
+"
+BDEPEND="media-gfx/imagemagick"
+
+EANT_BUILD_TARGET="build"
+
+src_install(){
+ insinto "opt/${PN}"
+ doins -r bin/*
+ chmod a+x "${ED}/opt/${PN}/fastqc"
+ # add convenience symlink
+ dosym ../${PN}/${PN} /opt/bin/${PN}
+
+ convert ${PN}_icon.ico ${PN}.png || die
+ doicon ${PN}.png
+ make_desktop_entry ${PN} FastQC ${PN}
+ einstalldocs
+}
diff --git a/sci-biology/fastqc/files/00fastqc b/sci-biology/fastqc/files/00fastqc
deleted file mode 100644
index 021de8bb0..000000000
--- a/sci-biology/fastqc/files/00fastqc
+++ /dev/null
@@ -1 +0,0 @@
-PATH="/opt/fastqc/bin"
diff --git a/sci-biology/fastqc/files/build.xml b/sci-biology/fastqc/files/build.xml
deleted file mode 100644
index c4a692096..000000000
--- a/sci-biology/fastqc/files/build.xml
+++ /dev/null
@@ -1,59 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<!-- WARNING: Eclipse auto-generated file.
- Any modifications will be overwritten.
- To include a user specific buildfile here, simply create one in the same
- directory with the processing instruction <?eclipse.ant.import?>
- as the first entry and export the buildfile again. -->
-<project basedir="." default="build" name="FastQC">
- <property environment="env"/>
- <property name="debuglevel" value="source,lines,vars"/>
- <property name="target" value="1.5"/>
- <property name="source" value="1.5"/>
- <path id="FastQC.classpath">
- <pathelement location="bin"/>
- <pathelement location="jbzip2-0.9.jar"/>
- <pathelement location="sam-1.103.jar"/>
- <pathelement location="cisd-jhdf5.jar"/>
- </path>
- <target name="init">
- <mkdir dir="bin"/>
- <copy includeemptydirs="false" todir="bin">
- <fileset dir=".">
- <exclude name="**/*.launch"/>
- <exclude name="**/*.java"/>
- </fileset>
- </copy>
- </target>
- <target name="clean">
- <delete dir="bin"/>
- </target>
- <target depends="clean" name="cleanall"/>
- <target depends="build-subprojects,build-project" name="build"/>
- <target name="build-subprojects"/>
- <target depends="init" name="build-project">
- <echo message="${ant.project.name}: ${ant.file}"/>
- <javac debug="true" debuglevel="${debuglevel}" destdir="bin" includeantruntime="false" source="${source}" target="${target}">
- <src path="."/>
- <classpath refid="FastQC.classpath"/>
- </javac>
- </target>
- <target description="Build all projects which reference this project. Useful to propagate changes." name="build-refprojects"/>
- <target description="copy Eclipse compiler jars to ant lib directory" name="init-eclipse-compiler">
- <copy todir="${ant.library.dir}">
- <fileset dir="${ECLIPSE_HOME}/plugins" includes="org.eclipse.jdt.core_*.jar"/>
- </copy>
- <unzip dest="${ant.library.dir}">
- <patternset includes="jdtCompilerAdapter.jar"/>
- <fileset dir="${ECLIPSE_HOME}/plugins" includes="org.eclipse.jdt.core_*.jar"/>
- </unzip>
- </target>
- <target description="compile project with Eclipse compiler" name="build-eclipse-compiler">
- <property name="build.compiler" value="org.eclipse.jdt.core.JDTCompilerAdapter"/>
- <antcall target="build"/>
- </target>
- <target name="FastQCApplication">
- <java classname="uk.ac.babraham.FastQC.FastQCApplication" failonerror="true" fork="yes">
- <classpath refid="FastQC.classpath"/>
- </java>
- </target>
-</project>
diff --git a/sci-biology/fastqc/metadata.xml b/sci-biology/fastqc/metadata.xml
index 7c86089a2..f13c6ccba 100644
--- a/sci-biology/fastqc/metadata.xml
+++ b/sci-biology/fastqc/metadata.xml
@@ -13,4 +13,7 @@
<email>sci-biology@gentoo.org</email>
<name>Gentoo Biology Project</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">s-andrews/FastQC</remote-id>
+ </upstream>
</pkgmetadata>