aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/dolfin/files')
-rw-r--r--sci-mathematics/dolfin/files/dolfin-0.9.9-find-armadillo.patch25
-rw-r--r--sci-mathematics/dolfin/files/dolfin-2016.2.0-trilinos-superlu.patch21
2 files changed, 0 insertions, 46 deletions
diff --git a/sci-mathematics/dolfin/files/dolfin-0.9.9-find-armadillo.patch b/sci-mathematics/dolfin/files/dolfin-0.9.9-find-armadillo.patch
deleted file mode 100644
index 677a78aab..000000000
--- a/sci-mathematics/dolfin/files/dolfin-0.9.9-find-armadillo.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -Naur a/cmake/modules/FindArmadillo.cmake b/cmake/modules/FindArmadillo.cmake
---- a/cmake/modules/FindArmadillo.cmake 2010-09-02 02:49:57.000000000 +0200
-+++ b/cmake/modules/FindArmadillo.cmake 2010-12-15 14:21:34.810300165 +0100
-@@ -95,8 +95,8 @@
- #include <armadillo>
- int main()
- {
-- arma::mat A = arma::rand(4, 4);
-- arma::vec b = arma::rand(4);
-+ arma::mat A = arma::randu(4, 4);
-+ arma::vec b = arma::randu(4);
- arma::vec x = arma::solve(A, b);
- return 0;
- }
-@@ -112,8 +112,8 @@
- #include <armadillo>
- int main()
- {
-- arma::mat A = arma::rand(4, 4);
-- arma::vec b = arma::rand(4);
-+ arma::mat A = arma::randu(4, 4);
-+ arma::vec b = arma::randu(4);
- arma::vec x = arma::solve(A, b);
- return 0;
- }
diff --git a/sci-mathematics/dolfin/files/dolfin-2016.2.0-trilinos-superlu.patch b/sci-mathematics/dolfin/files/dolfin-2016.2.0-trilinos-superlu.patch
deleted file mode 100644
index 7282766fe..000000000
--- a/sci-mathematics/dolfin/files/dolfin-2016.2.0-trilinos-superlu.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/dolfin/CMakeLists.txt b/dolfin/CMakeLists.txt
-index 26bc21a..0caf7ca 100644
---- a/dolfin/CMakeLists.txt
-+++ b/dolfin/CMakeLists.txt
-@@ -2,6 +2,7 @@ set(DOLFIN_H dolfin.h)
- install(FILES ${DOLFIN_H} DESTINATION ${DOLFIN_INCLUDE_DIR}
- COMPONENT Development)
-
-+
- # Configure and install dolfin/common/version.h file
- string(REPLACE "+" "" DOLFIN_VERSION_MICRO_STRIPPED ${DOLFIN_VERSION_MICRO})
- configure_file(${DOLFIN_SOURCE_DIR}/dolfin/common/version.h.in
-@@ -12,6 +13,8 @@ install(FILES ${CMAKE_BINARY_DIR}/dolfin/common/version.h
- )
- include_directories(${CMAKE_BINARY_DIR})
-
-+include_directories(/usr/include/superlu)
-+
- #------------------------------------------------------------------------------
- # DOLFIN source directories
-