aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/elmer-fem/elmer-fem-9999.ebuild')
-rw-r--r--sci-misc/elmer-fem/elmer-fem-9999.ebuild65
1 files changed, 28 insertions, 37 deletions
diff --git a/sci-misc/elmer-fem/elmer-fem-9999.ebuild b/sci-misc/elmer-fem/elmer-fem-9999.ebuild
index 9d970831f..0c1260da1 100644
--- a/sci-misc/elmer-fem/elmer-fem-9999.ebuild
+++ b/sci-misc/elmer-fem/elmer-fem-9999.ebuild
@@ -1,27 +1,29 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="4"
+EAPI=5
-inherit autotools eutils subversion
+AUTOTOOLS_AUTORECONF=true
+FORTRAN_STANDARD=90
+
+inherit autotools-utils fortran-2 multilib subversion
ELMER_ROOT="elmerfem"
MY_PN=${PN/elmer-/}
-DESCRIPTION="Elmer is a collection of finite element programs, libraries, and visualization tools, main fem"
+DESCRIPTION="Finite element programs, libraries, and visualization tools - main fem"
HOMEPAGE="http://www.csc.fi/english/pages/elmer"
-#SRC_URI="http://elmerfem.svn.sourceforge.net/viewvc/${ELMER_ROOT}/release/${PV}/${MY_PN}/?view=tar -> ${P}.tar.gz"
SRC_URI=""
-RESTRICT="mirror"
ESVN_REPO_URI="https://elmerfem.svn.sourceforge.net/svnroot/elmerfem/trunk/${MY_PN}"
ESVN_PROJECT="${MY_PN}"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS=""
IUSE="mpi debug"
-DEPEND="sys-libs/glibc
+
+RDEPEND="
virtual/blas
virtual/lapack
sci-libs/arpack
@@ -29,37 +31,26 @@ DEPEND="sys-libs/glibc
sci-libs/elmer-hutiter
sci-libs/elmer-eio
mpi? ( sys-cluster/mpich2 )"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}"
+# Note this seems to only configure correctly with the elmer version of umfpack
+# But this doesn't stop it from compiling / working without it
-S="${WORKDIR}/${PV}/fem"
+S="${WORKDIR}/fem"
-src_prepare() {
- #unpack ${A}
- cd "${S}"
- # configure must be executable
- #chmod +x configure
- epatch ${FILESDIR}/elmer-fem-Makefile-install.patch
- eautoreconf
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.0_p4651-oos.patch
+ "${FILESDIR}"/${PN}-6.0_p4651-underlinking.patch
+)
src_configure() {
- cd "${S}"
- local myconf
- export FC="gfortran"
- export F77="gfortran"
- myconf="$myconf --with-blas --with-lapack --with-arpack --with-huti"
- myconf="$myconf --with-eiof --with-matc"
- #TODO parpack support is not picked up from the arpack package
- #TODO --with-hypre --with-umfpack
-
- use mpi && myconf="$myconf --with-mpi --with-mpi-dir=/usr"
- use debug &&
- myconf="${myconf} --with-debug" ||
- myconf="${myconf} --without-debug"
- econf $myconf || die "econf failed"
-}
-
-
-src_install() {
- emake ELMER_SOLVER_DATADIR="/usr/share/elmersolver" DESTDIR=${D} install || die "emake install failed"
+ local myeconfargs=(
+ $(use_with debug)
+ $(usex mpi --with-mpi "")
+ $(usex mpi --with-mpi-dir="${EPREFIX}"/usr "")
+ --with-arpack="$($(tc-getPKG_CONFIG) --libs arpack)"
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
+ --with-huti --with-eiof --with-matc
+ )
+ autotools-utils_src_configure
}