aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/elmer-fem/ChangeLog12
-rw-r--r--sci-misc/elmer-fem/Manifest2
-rw-r--r--sci-misc/elmer-fem/elmer-fem-5.4.1-r1.ebuild65
-rw-r--r--sci-misc/elmer-fem/elmer-fem-6.0_p4651.ebuild54
-rw-r--r--sci-misc/elmer-fem/elmer-fem-9999.ebuild65
-rw-r--r--sci-misc/elmer-fem/files/elmer-fem-6.0_p4651-oos.patch75
-rw-r--r--sci-misc/elmer-fem/files/elmer-fem-6.0_p4651-underlinking.patch23
-rw-r--r--sci-misc/elmer-fem/metadata.xml5
8 files changed, 198 insertions, 103 deletions
diff --git a/sci-misc/elmer-fem/ChangeLog b/sci-misc/elmer-fem/ChangeLog
new file mode 100644
index 000000000..de1bf372c
--- /dev/null
+++ b/sci-misc/elmer-fem/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for sci-misc/elmer-fem
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*elmer-fem-6.0_p4651 (03 Dec 2013)
+
+ 03 Dec 2013; Justin Lecher <jlec@gentoo.org> -elmer-fem-5.4.1-r1.ebuild,
+ +elmer-fem-6.0_p4651.ebuild, elmer-fem-9999.ebuild,
+ +files/elmer-fem-6.0_p4651-oos.patch,
+ +files/elmer-fem-6.0_p4651-underlinking.patch, +metadata.xml:
+ Bump EAPI; fix DESCRIPTION; drop keywords from live ebuild; fix whitespacing
+
diff --git a/sci-misc/elmer-fem/Manifest b/sci-misc/elmer-fem/Manifest
index 1097f1092..6b759e17e 100644
--- a/sci-misc/elmer-fem/Manifest
+++ b/sci-misc/elmer-fem/Manifest
@@ -1 +1 @@
-DIST elmer-fem-5.4.1.tar.gz 8436861 SHA256 bc7e6537f97e3c1ee5c32466978dc39b21cbd48638763a5c18717bfca2f8547b SHA512 edf97d00c9de9fe34dd595738eeaa676b299032bf25cfa4cf5c0de76e9254fdaa81dc534daef7b4168f19ff226dc55d742a8c3e40b0edbf04704634df919d25c WHIRLPOOL 84af0e107666bcfc4a7048f3320ef621b59918b3e3c6e35f831edaf78b2d7131a18f0d0ff9925707dc68e6e5b987213718af51331ed829c1f3109e22e1e92cb5
+DIST elmer-fem-6.0_p4651.tar.gz 10915056 SHA256 1672a7a4f1e1030fd66217563c73dc99f7ebdbec6880539c778c43d0e94e1eb8 SHA512 824e26193ca2b55651c1bdddd73b28d06dff47914855ed67353c941851ba57961c68c2dd28d19bd4e8406b67efeb997bf441a3225ecd1fb66cdc575cb4f575dd WHIRLPOOL 4e2e2f3e6cafccc47cfea618f40d0fd949448d38279fe8dc699cfbda7ff4dcf61495ddbb1b01a0d282a4091fbbf5d0f51cc31c15e37a7b3b2bbcd8a41f7b1255
diff --git a/sci-misc/elmer-fem/elmer-fem-5.4.1-r1.ebuild b/sci-misc/elmer-fem/elmer-fem-5.4.1-r1.ebuild
deleted file mode 100644
index ce60dcc86..000000000
--- a/sci-misc/elmer-fem/elmer-fem-5.4.1-r1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="4"
-
-inherit autotools eutils
-
-ELMER_ROOT="elmerfem"
-MY_PN=${PN/elmer-/}
-
-DESCRIPTION="Elmer is a collection of finite element programs, libraries, and visualization tools, main fem"
-HOMEPAGE="http://www.csc.fi/english/pages/elmer"
-SRC_URI="http://elmerfem.svn.sourceforge.net/viewvc/${ELMER_ROOT}/release/${PV}/${MY_PN}/?view=tar -> ${P}.tar.gz"
-RESTRICT="mirror"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE="mpi debug"
-DEPEND="sys-libs/glibc
- virtual/blas
- virtual/lapack
- sci-libs/arpack
- sci-libs/matc
- sci-libs/elmer-hutiter
- sci-libs/elmer-eio
- mpi? ( sys-cluster/mpich2 )"
-RDEPEND="${DEPEND}"
-# Note this seems to only configure correctly with the elmer version of umfpack
-# But this doesn't stop it from compiling / working without it
-
-S="${WORKDIR}/${PV}/fem"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # configure must be executable
- chmod +x configure
- epatch ${FILESDIR}/elmer-fem-Makefile-install.patch
- eautoreconf
-}
-
-src_compile() {
- cd "${S}"
- local myconf
- export FC="gfortran"
- export F77="gfortran"
- myconf="$myconf --with-blas --with-lapack --with-arpack --with-huti"
- myconf="$myconf --with-eiof --with-matc"
- #TODO parpack support is not picked up from the arpack package
- #TODO --with-hypre --with-umfpack
-
- use mpi && myconf="$myconf --with-mpi --with-mpi-dir=/usr"
- use debug &&
- myconf="${myconf} --with-debug" ||
- myconf="${myconf} --without-debug"
- econf $myconf || die "econf failed"
- emake || die "emake failed"
-}
-
-
-src_install() {
- emake ELMER_SOLVER_DATADIR="${D}/usr/share/elmersolver" DESTDIR="${D}" install || die "emake install failed"
-}
diff --git a/sci-misc/elmer-fem/elmer-fem-6.0_p4651.ebuild b/sci-misc/elmer-fem/elmer-fem-6.0_p4651.ebuild
new file mode 100644
index 000000000..d8289c2a8
--- /dev/null
+++ b/sci-misc/elmer-fem/elmer-fem-6.0_p4651.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+FORTRAN_STANDARD=90
+
+inherit autotools-utils fortran-2 multilib
+
+ELMER_ROOT="elmerfem"
+MY_PN=${PN/elmer-/}
+
+DESCRIPTION="Finite element programs, libraries, and visualization tools - main fem"
+HOMEPAGE="http://www.csc.fi/english/pages/elmer"
+SRC_URI="http://elmerfem.svn.sourceforge.net/viewvc/${ELMER_ROOT}/release/${PV%_p*}/${MY_PN}/?view=tar&pathrev=4651 -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mpi debug"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack
+ sci-libs/arpack
+ sci-libs/matc
+ sci-libs/elmer-hutiter
+ sci-libs/elmer-eio
+ mpi? ( sys-cluster/mpich2 )"
+DEPEND="${RDEPEND}"
+# Note this seems to only configure correctly with the elmer version of umfpack
+# But this doesn't stop it from compiling / working without it
+
+S="${WORKDIR}/fem"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-oos.patch
+ "${FILESDIR}"/${P}-underlinking.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with debug)
+ $(usex mpi --with-mpi "")
+ $(usex mpi --with-mpi-dir="${EPREFIX}"/usr "")
+ --with-arpack="$($(tc-getPKG_CONFIG) --libs arpack)"
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
+ --with-huti --with-eiof --with-matc
+ )
+ autotools-utils_src_configure
+}
diff --git a/sci-misc/elmer-fem/elmer-fem-9999.ebuild b/sci-misc/elmer-fem/elmer-fem-9999.ebuild
index 9d970831f..0c1260da1 100644
--- a/sci-misc/elmer-fem/elmer-fem-9999.ebuild
+++ b/sci-misc/elmer-fem/elmer-fem-9999.ebuild
@@ -1,27 +1,29 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="4"
+EAPI=5
-inherit autotools eutils subversion
+AUTOTOOLS_AUTORECONF=true
+FORTRAN_STANDARD=90
+
+inherit autotools-utils fortran-2 multilib subversion
ELMER_ROOT="elmerfem"
MY_PN=${PN/elmer-/}
-DESCRIPTION="Elmer is a collection of finite element programs, libraries, and visualization tools, main fem"
+DESCRIPTION="Finite element programs, libraries, and visualization tools - main fem"
HOMEPAGE="http://www.csc.fi/english/pages/elmer"
-#SRC_URI="http://elmerfem.svn.sourceforge.net/viewvc/${ELMER_ROOT}/release/${PV}/${MY_PN}/?view=tar -> ${P}.tar.gz"
SRC_URI=""
-RESTRICT="mirror"
ESVN_REPO_URI="https://elmerfem.svn.sourceforge.net/svnroot/elmerfem/trunk/${MY_PN}"
ESVN_PROJECT="${MY_PN}"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS=""
IUSE="mpi debug"
-DEPEND="sys-libs/glibc
+
+RDEPEND="
virtual/blas
virtual/lapack
sci-libs/arpack
@@ -29,37 +31,26 @@ DEPEND="sys-libs/glibc
sci-libs/elmer-hutiter
sci-libs/elmer-eio
mpi? ( sys-cluster/mpich2 )"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}"
+# Note this seems to only configure correctly with the elmer version of umfpack
+# But this doesn't stop it from compiling / working without it
-S="${WORKDIR}/${PV}/fem"
+S="${WORKDIR}/fem"
-src_prepare() {
- #unpack ${A}
- cd "${S}"
- # configure must be executable
- #chmod +x configure
- epatch ${FILESDIR}/elmer-fem-Makefile-install.patch
- eautoreconf
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.0_p4651-oos.patch
+ "${FILESDIR}"/${PN}-6.0_p4651-underlinking.patch
+)
src_configure() {
- cd "${S}"
- local myconf
- export FC="gfortran"
- export F77="gfortran"
- myconf="$myconf --with-blas --with-lapack --with-arpack --with-huti"
- myconf="$myconf --with-eiof --with-matc"
- #TODO parpack support is not picked up from the arpack package
- #TODO --with-hypre --with-umfpack
-
- use mpi && myconf="$myconf --with-mpi --with-mpi-dir=/usr"
- use debug &&
- myconf="${myconf} --with-debug" ||
- myconf="${myconf} --without-debug"
- econf $myconf || die "econf failed"
-}
-
-
-src_install() {
- emake ELMER_SOLVER_DATADIR="/usr/share/elmersolver" DESTDIR=${D} install || die "emake install failed"
+ local myeconfargs=(
+ $(use_with debug)
+ $(usex mpi --with-mpi "")
+ $(usex mpi --with-mpi-dir="${EPREFIX}"/usr "")
+ --with-arpack="$($(tc-getPKG_CONFIG) --libs arpack)"
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
+ --with-huti --with-eiof --with-matc
+ )
+ autotools-utils_src_configure
}
diff --git a/sci-misc/elmer-fem/files/elmer-fem-6.0_p4651-oos.patch b/sci-misc/elmer-fem/files/elmer-fem-6.0_p4651-oos.patch
new file mode 100644
index 000000000..00291bc56
--- /dev/null
+++ b/sci-misc/elmer-fem/files/elmer-fem-6.0_p4651-oos.patch
@@ -0,0 +1,75 @@
+ src/Makefile.am | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 9e48c31..b94705c 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -182,11 +182,11 @@ SC2Elmer_SOURCES = SC2Elmer.c
+
+ if USE_LOCAL_MPIF_H
+ mpif: mpif_stub.h
+- $(CP) mpif_stub.h mpif.h
+- $(CP) mpif_stub.h mpif
++ $(CP) $(srcdir)/mpif_stub.h mpif.h
++ $(CP) $(srcdir)/mpif_stub.h mpif
+ else
+ mpif: mpif_stub.h
+- $(CP) mpif_stub.h mpif
++ $(CP) $(srcdir)/mpif_stub.h mpif
+ endif
+
+ EXTRA_DIST = \
+ src/Makefile.am | 25 +++++++++++++------------
+ 1 file changed, 13 insertions(+), 12 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 92de7a4..89a2236 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -144,32 +144,33 @@ ELMER_SOLVER_DATADIR=$(prefix)/share/elmersolver
+ install-data-local:
+ @echo "Installing solvers to ${ELMER_SOLVER_DATADIR}/lib"
+
+- mkdir -p $(DESTDIR)$(ELMER_SOLVER_DATADIR)/lib
+- $(CP) `ls -f *$(SHL_EXT) | grep -v libelmersolver` $(DESTDIR)$(ELMER_SOLVER_DATADIR)/lib
+- $(CP) elements.def $(DESTDIR)$(ELMER_SOLVER_DATADIR)/lib
+- $(CP) SOLVER.KEYWORDS $(DESTDIR)$(ELMER_SOLVER_DATADIR)/lib
++ mkdir -p $(DESTDIR)$(ELMER_SOLVER_DATADIR)/$(libdir)
++ $(CP) `ls -f $(builddir)/*$(SHL_EXT) | grep -v libelmersolver` $(DESTDIR)$(ELMER_SOLVER_DATADIR)/$(libdir)
++ $(CP) $(srcdir)/elements.def $(DESTDIR)$(ELMER_SOLVER_DATADIR)/$(libdir)
++ $(CP) $(srcdir)/SOLVER.KEYWORDS $(DESTDIR)$(ELMER_SOLVER_DATADIR)/$(libdir)
+
+ @echo "Installing *.mod to ${ELMER_SOLVER_DATADIR}/include"
+ mkdir -p $(DESTDIR)$(ELMER_SOLVER_DATADIR)/include
+- $(CP) *.mod $(DESTDIR)$(ELMER_SOLVER_DATADIR)/include
++ $(CP) $(builddir)/*.mod $(DESTDIR)$(ELMER_SOLVER_DATADIR)/include
+
+
+ install-exec-local:
+ @echo "Installing stuff to ${prefix}/bin"
+ $(MKDIR) $(DESTDIR)$(prefix)/bin
+- $(CP) ElmerSolver$(EXEEXT) $(DESTDIR)$(prefix)/bin
+- $(CP) ViewFactors$(EXEEXT) $(DESTDIR)$(prefix)/bin
+- $(CP) GebhardtFactors$(EXEEXT) $(DESTDIR)$(prefix)/bin
++ $(CP) $(builddir)/ElmerSolver$(EXEEXT) $(DESTDIR)$(prefix)/bin
++ $(CP) $(builddir)/ViewFactors$(EXEEXT) $(DESTDIR)$(prefix)/bin
++ $(CP) $(builddir)/GebhardtFactors$(EXEEXT) $(DESTDIR)$(prefix)/bin
+ if USE_WINDOWS_COMPILER
+ $(CP) libelmersolver*$(SHL_EXT) $(DESTDIR)$(prefix)/lib
+ else
+- $(CP) libelmersolver-$(VERSION)$(SHL_EXT) $(DESTDIR)$(prefix)/lib
++ mkdir -p $(DESTDIR)$(prefix)/$(libdir)
++ $(CP) $(builddir)/libelmersolver-$(VERSION)$(SHL_EXT) $(DESTDIR)$(prefix)/$(libdir)
+ $(LN) -sf libelmersolver-$(VERSION)$(SHL_EXT)\
+- $(DESTDIR)$(prefix)/lib/libelmersolver$(SHL_EXT)
++ $(DESTDIR)$(prefix)/$(libdir)/libelmersolver$(SHL_EXT)
+ endif
+- $(CP) elmerf90 elmerf90-nosh elmerld $(DESTDIR)$(prefix)/bin
++ $(CP) $(builddir)/elmerf90 $(builddir)/elmerf90-nosh elmerld $(DESTDIR)$(prefix)/bin
+ if USE_MPI
+- $(CP) ElmerSolver_mpi$(EXEEXT) $(DESTDIR)$(prefix)/bin
++ $(CP) $(builddir)/ElmerSolver_mpi$(EXEEXT) $(DESTDIR)$(prefix)/bin
+ endif
+
+ clean-local:
diff --git a/sci-misc/elmer-fem/files/elmer-fem-6.0_p4651-underlinking.patch b/sci-misc/elmer-fem/files/elmer-fem-6.0_p4651-underlinking.patch
new file mode 100644
index 000000000..7c6be1d8c
--- /dev/null
+++ b/sci-misc/elmer-fem/files/elmer-fem-6.0_p4651-underlinking.patch
@@ -0,0 +1,23 @@
+ src/Makefile.am | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index b94705c..92de7a4 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -122,13 +122,13 @@ if USE_WINDOWS_COMPILER
+ else
+ $(FC) $(SH_LINKING_TO_FLAGS) $(RPATH_ELMER) $(B64FLAGS) $(LDFLAGS) \
+ -o ViewFactors$(EXE_EXT) ViewFactors$(OBJ_EXT) mpi_stubs$(OBJ_EXT) \
+- -L. -lelmersolver viewaxis/libviewaxis.a view3d/libview3d.a $(EXTRA_LIBS) $(BLAS_LIBS) $(STDCXX_LIBS)
++ -L. -lelmersolver viewaxis/libviewaxis.a view3d/libview3d.a $(EXTRA_LIBS) $(BLAS_LIBS) $(STDCXX_LIBS) -lhuti
+ endif
+
+ GebhardtFactors$(EXE_EXT): libelmersolver$(SHL_EXT) GebhardtFactors$(OBJ_EXT) mpi_stubs$(OBJ_EXT)
+ $(FC) $(SH_LINKING_TO_FLAGS) $(RPATH_ELMER) $(B64FLAGS) $(LDFLAGS) \
+ -o GebhardtFactors$(EXE_EXT) GebhardtFactors$(OBJ_EXT) mpi_stubs$(OBJ_EXT) \
+- -L. -lelmersolver viewaxis/libviewaxis.a view3d/libview3d.a $(EXTRA_LIBS)
++ -L. -lelmersolver viewaxis/libviewaxis.a view3d/libview3d.a $(EXTRA_LIBS) -lhuti
+
+
+
diff --git a/sci-misc/elmer-fem/metadata.xml b/sci-misc/elmer-fem/metadata.xml
new file mode 100644
index 000000000..897aa2e6b
--- /dev/null
+++ b/sci-misc/elmer-fem/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+</pkgmetadata>