aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/uproot/uproot-5.3.1.ebuild')
-rw-r--r--sci-physics/uproot/uproot-5.3.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-physics/uproot/uproot-5.3.1.ebuild b/sci-physics/uproot/uproot-5.3.1.ebuild
new file mode 100644
index 000000000..cfc3880e9
--- /dev/null
+++ b/sci-physics/uproot/uproot-5.3.1.ebuild
@@ -0,0 +1,28 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=hatchling
+SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+inherit distutils-r1 pypi
+
+DESCRIPTION="ROOT I/O in pure Python and Numpy."
+HOMEPAGE="https://github.com/scikit-hep/uproot"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/awkward-2.4.6[${PYTHON_USEDEP}]
+ >=dev-python/cramjam-2.5.0[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/fsspec[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+# way too many missing packages, isal, deflate, xxhash, http servers etc
+# distutils_enable_tests pytest