aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/uproot')
-rw-r--r--sci-physics/uproot/Manifest1
-rw-r--r--sci-physics/uproot/metadata.xml21
-rw-r--r--sci-physics/uproot/uproot-5.3.1.ebuild28
3 files changed, 50 insertions, 0 deletions
diff --git a/sci-physics/uproot/Manifest b/sci-physics/uproot/Manifest
new file mode 100644
index 000000000..bb52077be
--- /dev/null
+++ b/sci-physics/uproot/Manifest
@@ -0,0 +1 @@
+DIST uproot-5.3.1.tar.gz 919910 BLAKE2B 6c138a56ecabb08905e1edde8c776c3dfae6cca3213bbc3546e7241979052178e1c9718c1fcf298573669bcc4c004806cd54ab16050405038f76f3ef356fb184 SHA512 2525f372caa3b25e3a11b170ce981ce253a7b9ca1fdb2c04b6bb1093b166d206a28e9bc22ffa19dead76870f521cee44a812cbf41a087b34fb9a3bc52c210733
diff --git a/sci-physics/uproot/metadata.xml b/sci-physics/uproot/metadata.xml
new file mode 100644
index 000000000..1b293facb
--- /dev/null
+++ b/sci-physics/uproot/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>alexander@neuwirth-informatik.de</email>
+ <name>Alexander Puck Neuwirth</name>
+ </maintainer>
+ <longdescription lang="en">
+ Uproot is a library for reading and writing ROOT files in pure Python and NumPy.
+
+ Unlike the standard C++ ROOT implementation, Uproot is only an I/O library, primarily intended to stream data into machine learning libraries in Python. Unlike PyROOT and root_numpy, Uproot does not depend on C++ ROOT. Instead, it uses Numpy to cast blocks of data from the ROOT file as Numpy arrays.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">uproot</remote-id>
+ <remote-id type="github">scikit-hep/uproot5</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-physics/uproot/uproot-5.3.1.ebuild b/sci-physics/uproot/uproot-5.3.1.ebuild
new file mode 100644
index 000000000..cfc3880e9
--- /dev/null
+++ b/sci-physics/uproot/uproot-5.3.1.ebuild
@@ -0,0 +1,28 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=hatchling
+SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+inherit distutils-r1 pypi
+
+DESCRIPTION="ROOT I/O in pure Python and Numpy."
+HOMEPAGE="https://github.com/scikit-hep/uproot"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/awkward-2.4.6[${PYTHON_USEDEP}]
+ >=dev-python/cramjam-2.5.0[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/fsspec[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+# way too many missing packages, isal, deflate, xxhash, http servers etc
+# distutils_enable_tests pytest